Wykresy — informacje

Wykresy są atrakcyjne wizualnie i ułatwiają przedstawienie użytkownikom porównań, prawidłowości i trendów danych. Używając składnika Microsoft Office Chart Component można utworzyć dynamiczne, interaktywne wykresy do oglądania w przeglądarce w udostępnionej witrynie sieci Web. Gdy zmieniają się dane wykresu i jest odświeżana strona sieci Web zawierająca wykres, wówczas wykres jest automatycznie aktualizowany, aby odzwierciedlić najnowsze dane.

Wykres i arkusz kalkulacyjny na stronie sieci Web

Wykresy mogą korzystać z danych wprowadzonych w arkuszu danych, istniejące dane z tabel i kwerend baz danych lub arkuszy kalkulacyjnych i list tabel przestawnych utworzonych za pomocą składników Microsoft Office Web Components. Gdy dane są oparte na liście tabeli przestawnej lub tabeli albo kwerendzie bazy danych, wówczas można dodać pola w celu zorganizowania danych, a następnie zmienić ich rozmieszczenie, a także sortować i filtrować dane.

Zanim rozpoczniesz

Sprawdź, czy użytkownicy mogą interaktywnie pracować z wykresem Zanim rozpoczniesz projektowanie wykresu, zastanów się jakiego programu użyć do projektowania i czy użytkownicy mają wymaganą przeglądarkę, a także dostęp do składników Microsoft Office Web Components konieczny do interaktywnej pracy z wykresem.

Aby pracować z wykresami, użytkownicy muszą mieć zainstalowane składniki Office Web Components. Mogą je mieć, instalując pakiet Microsoft Office XP lub (jeśli firma wykupiła licencję na używanie pakietu Office XP w lokalizacji) pobierając składniki Microsoft Office Web Components z firmowego intranetu. Do interaktywnej pracy z wykresami użytkownicy muszą mieć także program Microsoft Internet Explorer w wersji 4.01 lub nowszej, jeśli wykres nie jest tworzony do użytku w projekcie VBA (Visual Basic for Applications).

Użytkownicy, których systemy nie spełniają powyższych wymagań, mogą wyświetlać wykresy, ale nie mogą z nimi interaktywnie pracować.

Wybieranie programu do projektowania Program do projektowania to program używany do tworzenia lub modyfikowania wykresów. Różne programy do projektowania mają różne funkcje. Na przykład można użyć do utworzenia wykresu różnorodnych funkcji kreślenia wykresów programu Microsoft Excel, a następnie zapisać lub opublikować wykres jako wykres statyczny (obraz) albo wykres interaktywny. Można również użyć narzędzi w programie Microsoft FrontPage do utworzenia dynamicznych stron sieci Web zawierających wykresy, a następnie opublikować strony w witrynie sieci Web. Można również użyć programu Microsoft Access, aby skorzystać z funkcji automatycznego połączenia baz danych. Można otworzyć stronę sieci Web zawierającą wykres i zmodyfikować wykres w programach FrontPage lub Access. Do otwierania i modyfikowania wykresu, który został opublikowany na stronie sieci Web lub jako strona sieci Web nie można użyć programu Excel.

Przygotowanie danych źródłowych, których chcesz użyć w swoim wykresie

Dane wykresu można wprowadzić w arkuszu danych wykresu lub użyć danych z bazy danych, składnika Microsoft Office Spreadsheet Component lub Microsoft Office PivotTable Component.

Aby wykreślić dane z arkusza lub z listy tabeli przestawnej, należy najpierw otworzyć stronę sieci Web, która zawiera jeden z tych składników lub utworzyć nowy formant z danymi, których chcesz użyć na stronie sieci Web.

Aby wykreślić dane z kwerendy bazy danych, należy najpierw utworzyć kwerendę. Na przykład, jeżeli masz tabelę zawierającą wartości rocznej sprzedaży dla pięciu lat, a chcesz wykreślić wartości tylko dla jednego z tych lat, to możesz uruchomić kwerendę zwracającą wartości sprzedaży dla żądanego roku, a następnie użyć kwerendy jako danych źródłowych wykresu.

Programy do projektowania, w których można tworzyć wykresy

Wykresy przeznaczone do sieci Web można tworzyć i modyfikować za pomocą wielu programów. Można utworzyć wykres w jednym programie, a następnie użyć innego programu do zmodyfikowania wykresu lub strony sieci Web, na której wykres się znajduje. Wybór programu do projektowania zależy od ilości pracy związanej z projektowaniem lub administrowaniem stroną sieci Web, typu danych źródłowych, które mają być używane, a także od zaznajomienia użytkownika z różnymi programami do projektowania.

Program Microsoft Excel

Jeżeli dane źródłowe pochodzą z arkusza lub jeżeli chcesz spróbować różnych typów wykresów i dostosować dane źródłowe, które udostępniasz dla wykresu, to doskonałym środowiskiem projektowania będzie program Excel. Jeżeli publikujesz wykres za pomocą programu Excel, to określone dane źródłowe są automatycznie dołączane do wykresu i publikowane na tej samej stronie jako interaktywny arkusz lub lista tabeli przestawnej.

Po opublikowaniu wykresu za pomocą programu Excel można zmodyfikować oryginalny wykres w programie Excel (jeżeli został zapisany plik xls) i ponownie go opublikować, ale nie można zmodyfikować opublikowanego wykresu w programie Excel. Można natomiast otworzyć stronę sieci Web z opublikowanym wykresem w programie FrontPage lub w widoku Projektu strony dostępu do danych w programie Microsoft Access, a następnie zmodyfikować zarówno wykres, jak i stronę sieci Web.

Program Microsoft Excel jest dostępny w pakiecie Microsoft Office XP.

Program Microsoft FrontPage

Za pomocą programu FrontPage można tworzyć i modyfikować wykresy przeznaczone do sieci Web. Można również używać różnorodnych funkcji edytowania i funkcji administracyjnych stron sieci Web w celu dodawania do strony sieci Web innych formantów, grafiki, motywów i innych elementów, a następnie włączyć tę stronę jako część witryny sieci Web.

Program Microsoft FrontPage jest dostępny w pakiecie Microsoft Office XP.

Program Microsoft Access

W dziedzinie tworzenia stron sieci Web program Access udostępnia specjalne funkcje umożliwiające wykonywanie operacji na danych z baz danych i wyświetlanie ich. Można użyć programu Access do utworzenia połączenia pomiędzy bazą danych programu Access i żądanymi danymi źródłowymi wykresu, a następnie użyć automatycznych funkcji w widoku Projektu strony dostępu do danych w celu dołączenia danych do wykresu. Na przykład można upuścić tabelę na stronie sieci Web za pomocą listy pól, a następnie utworzyć wykres na stronie sieci Web używający danych z tej tabeli. Można również ustanowić połączenia pomiędzy wykresami i innymi formantami, które wyświetlają dane z baz danych na stronie sieci Web i operują na nich. Aby utworzyć wykresy dla użytkowników korzystających z programu Internet Explorer 5 lub w wersji nowszej, użyj widoku Projektu strony dostępu do danych w programie Access.

Program Microsoft Access jest dostępny w pakiecie Microsoft Office XP.

Program Microsoft Visual Basic

Jeżeli programujesz i potrzebujesz bardziej wszechstronnego środowiska programowania, a nie tylko możliwości tworzenia skryptów w edytorze Microsoft Script Editor, w programie Excel lub Access, to możesz tworzyć wykresy za pomocą języka programowania Visual Basic. Uzyskiwanie pomocy na temat programowania wykresu dla sieci Web.

Tworzenie wykresu

Gdy dane, które mają być użyte na wykresie są już przygotowane, postępuj zgodnie z instrukcjami w programie do projektowania, aby umieścić składnik Chart Component na stronie sieci Web.

Gdy umieszczasz wykres na stronie sieci Web, wyświetlane jest okno dialogowe Polecenia i opcje danego wykresu. W tym oknie dialogowym można wybrać typ wykresu, którego chcesz użyć oraz, w zależności od typu używanych danych, wybrać żądany sposób wyświetlania danych.

Dostosowywanie wykresu

Po utworzeniu wykresu można użyć okna dialogowego Polecenia i opcje lub paska narzędzi wykresu do zmiany typu wykresu, podziału danych między wiele wykresów w tym samym obszarze składnika, do zmiany opcji formatowania, dodania etykiet i tytułów, zmiany czcionki i stylu czcionki, itp.

Okno dialogowe Polecenia i opcje zawiera przyciski poleceń i opcje formatowania wyglądu wykresu. Można na przykład zmienić kolor znaczników danych, położenie legendy lub odstępy wartości na osi. Opcje w tym oknie dialogowym są rozłożone w kilku sekcjach nazywanych kartami. Dostępne karty zmieniają się w zależności od tego, która część wykresu jest w danej chwili zaznaczona. Na przykład, gdy zaznaczysz legendę wykresu, są dostępne jedynie karty związane z legendą — takie jak Ogólne, Format i Obramowanie/Wypełnienie. Gdy zaznaczysz oś, wyświetlane są karty takie jak Linia/Znacznik, Oś i Skala.

Udostępnianie instrukcji niestandardowych Można dodać opisowy tekst lub inne informacje dotyczące wykresu, wpisując je po prostu na stronie sieci Web.

Skrypty Do funkcji i możliwości składnika Chart Component można uzyskiwać dostęp za pomocą skryptów, które umożliwiają też sterowanie tymi funkcjami. Jeżeli umiesz pisać skrypty stron sieci Web w języku takim jak Visual Basic Scripting Edition (VBScript) lub JavaScript, to możesz dodawać skrypty do wykresu, aby zmienić jego wygląd lub udostępnić informacje użytkownikowi w odpowiedzi na informacje wprowadzane przez niego w przeglądarce.

Program do projektowania może udostępniać narzędzia do pisania skryptów. Na przykład pakiet Microsoft Office zawiera narzędzie Microsoft Script Editor. Aby uzyskać informacje o pisaniu skryptów, zapoznaj się z Pomocą w programie do projektowania. Aby uzyskać informacje o uzyskiwaniu dostępu do funkcji i narzędzi wykresu za pomocą skryptu, zapoznaj się z programowaniem Pomocy do składnika Chart Component.

Testowanie i publikowanie

Sprawdzanie wykresu w przeglądarce Przed udostępnieniem wykresu użytkownikom należy go przetestować w przeglądarce. Do pracy z wykresami zalecany jest program Microsoft Internet Explorer w wersji 5 lub nowszej. Do interaktywnej pracy z wykresem należy również mieć licencję pakietu Microsoft Office XP. Również użytkownicy programu Internet Explorer w wersji 4.01 lub nowszej posiadający licencję pakietu Office XP mogą przeglądać wykres i pracować z nim interaktywnie. Jeżeli użytkownicy korzystają z innych wersji przeglądarki, to warto przetestować wykres w każdej wersji, aby upewnić się, że wykres jest właściwie wyświetlany, a informacje są poprawnie aktualizowane.

Publikowanie strony sieci Web Jeżeli otrzymane wyniki są zadowalające, udostępnij stronę sieci Web użytkownikom. Aby uzyskać informacje dotyczące publikowania stron sieci Web, skorzystaj z Pomocy w programie do projektowania lub skonsultuj się w tej sprawie z Webmasterem lub administratorem sieci.


Przeglądarki obsługujące wykresy

Aby pracować interakcyjnie z wykresami w programie Microsoft Internet Explorer w wersji 4.01 lub nowszej, użytkownicy muszą zainstalować składniki Microsoft Office Web Components oraz posiadać odpowiednią licencję Office XP. Użytkownicy, którzy nie mają licencji Office XP, mogą zainstalować wspomniane składniki i przeglądać je na stronie sieci Web, ale nie mogą interakcyjnie z nimi pracować. Dowiedz się więcej na temat instalowania i licencjonowania składników.

Poniżej przedstawiono poziomy obsługi w przeglądarce, przy założeniu że użytkownik ma składniki Office Web Components oraz licencję Office XP.

Program Microsoft Internet Explorer 5 i nowszy

Użytkownicy mogą korzystać ze wszystkich funkcji wykresów dostępnych z poziomu przeglądarki. Zmiany wprowadzone przez użytkowników, takie jak formatowanie i zmiana układu, są zachowywane po opuszczeniu wykresu i powrocie do niego podczas tej samej sesji pracy z przeglądarką.

Program Microsoft Internet Explorer 4.01, 4.1x i 4.2x

Użytkownicy mogą korzystać ze wszystkich funkcji wykresu dostępnych z poziomu przeglądarki. Zmiany wprowadzone przez użytkowników są zachowywane po opuszczeniu wykresu i powrocie do niego podczas tej samej sesji pracy z przeglądarką. Aby przeglądać wykres na stronach dostępu do danych utworzonych w programie Microsoft Access, należy zainstalować program Internet Explorer 5.

Inne przeglądarki

We wcześniejszych wersjach programu Microsoft Internet Explorer i innych przeglądarkach nie można przeglądać wykresów. Wykresy są wyświetlane na stronie sieci Web w postaci pola otoczonego konturem lub wcale się nie pojawiają.


Składniki Microsoft Office Web Components — informacje

Składniki Microsoft Office Web Components to zestaw formantów ActiveX instalowanych z pakietem Microsoft Office XP. Zainstalowanie tych składników umożliwia interakcyjne korzystanie z arkusza kalkulacyjnego, listy tabeli przestawnej lub wykresu na stronach sieci Web wyświetlanych za pomocą przeglądarki Microsoft Internet Explorer w wersji 4.01 lub nowszej. Aby korzystać z tych składników na stronie dostępu do danych w programie Microsoft Access, należy zainstalować program Internet Explorer w wersji 5 lub nowszej.

Jeśli składniki nie są zainstalowane na komputerze użytkownika, ale ma on licencję wielostanowiskową Office XP zezwalającą na rozpowszechnianie w sieci intranet, to można tak skonfigurować składniki Office Web Components, aby inni użytkownicy byli monitowani o ich pobranie z firmowej sieci intranet. Dzięki temu mogą oni używać strony dostępu do danych bez konieczności instalowania aplikacji Office XP na swoich komputerach.

Aby uzyskać informacje dotyczące sposobu konfigurowania składników Office Web Components, zobacz zestaw Microsoft Office XP Resource Kit.


Instalowanie, licencjonowanie i rozpowszechnianie składników Office Web Components — informacje

Gdy zaprojektujesz stronę sieci Web za pomocą składników Microsoft Office Web Components, każdy użytkownik posiadający licencję pakietu Office XP będzie mógł interaktywnie pracować ze składnikami w przeglądarce, ale do zadeklarowanego przez projektanta poziomu interaktywności. To znaczy, że użytkownik z odpowiednią licencją może zmieniać dane w arkuszu kalkulacyjnym, zmieniać formatowanie, przeciągać pola na wykresie lub liście tabeli przestawnej i tak dalej, jeśli opcje te nie zostaną zastrzeżone podczas projektowania. Użytkownicy posiadający licencję pakietu Office XP mogą także tworzyć, projektować i modyfikować składniki w środowisku projektowania, takim jak programy Microsoft FrontPage lub Microsoft Access.

Użytkownicy nieposiadający licencji pakietu Office XP mogą wyświetlić składniki i zawarte w nich dane, mogą też wydrukować widok składników, ale nie mogą interaktywnie pracować ze składnikami ani operować nimi w środowisku projektowania. To znaczy, że gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy mający licencje pakietu Office XP, będą mieli dostęp do wszystkich funkcji, a użytkownicy bez licencji będą mogli jedynie wyświetlać dane i informacje, o ile są one podane.

Instalowanie składników Office Web Components

Składniki Microsoft Office Web Components są instalowane wraz z pakietem Microsoft Office XP i aplikacjami pakietu Microsoft Office lub mogą być zainstalowane oddzielnie z punktu instalacyjnego udostępnianego przez projektanta strony sieci Web.

Gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy, którzy nie mają zainstalowanych składników będą monitowani o zainstalowanie składników, o ile projektant strony sieci Web odpowiednio skonfiguruje składniki. Projektant strony sieci Web musi także udostępnić punkt instalacyjny składników i wskaźnik do tej lokalizacji na stronie instalacyjnej składników. Aby uzyskać więcej informacji, zapoznaj się z zestawem Microsoft Office XP Resource Kit.

Po zainstalowaniu składników Office Web Components użytkownicy, którzy mają dostęp do licencji pakietu Office XP będą mogli pracować interaktywnie ze składnikami i dokonywać w nich zmian. Użytkownicy bez licencji będą mogli wyświetlać i drukować składniki i zawarte w nich dane, ale nie będą mogli pracować interaktywnie ani dokonywać zmian.

Szczegółowe informacje o licencjonowaniu i funkcjach

Pakiet Microsoft Office XP zainstalowany na komputerze Użytkownicy dysponują wszystkimi funkcjami i mogą interaktywnie pracować ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania.

Aplikacja pakietu Microsoft Office XP zainstalowana na komputerze Użytkownicy mogą pracować interaktywnie ze składnikiem w trybie projektowania jedynie w tej aplikacji (a nie w przeglądarce ani w innych aplikacjach).

Licencja pakietu Microsoft Office XP w trybie dostępu z lokalizacji (użytkownik nie ma zainstalowanego na swoim komputerze pakietu Office XP, ale organizacja lub przedsiębiorstwo mają umowę licencyjną w trybie dostępu z lokalizacji) Użytkownicy dysponują wszystkimi funkcjami i mogą pracować interaktywnie ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania. Projektant strony sieci Web musi natomiast podać lokalizację, z której można pobrać składniki oraz musi odwołać się do licencji w trybie dostępu z lokalizacji w pliku pakietu licencji (lpk), który jest skojarzony z co najmniej jedną stroną sieci Web. Do utworzenia odpowiedniego pliku licencji stron służy narzędzie License Package Authoring Tool. Więcej informacje można znaleźć w witrynie MSDN Online.

Brak pakietu Microsoft Office XP, aplikacji pakietu Microsoft Office XP lub licencji w trybie dostępu z lokalizacji Użytkownicy mogą wyświetlać i drukować składniki w trybie tylko do przeglądania, ale nie mogą pracować interaktywnie ze składnikami ani używać funkcji projektowania.


Tryb tylko do wyświetlania składników Office Web Components — informacje

Jeśli na komputerze użytkownika nie zainstalowano licencji pakietu Microsoft Office XP i nie jest ona dostępna za pośrednictwem jednej z aplikacji Microsoft Office XP, to istnieje możliwość wyświetlenia składników Microsoft Office Web Component — Arkusza kalkulacyjnego, Wykresu lub Tabeli przestawnej — na stronie sieci Web, ale nie można z nich korzystać w sposób interakcyjny.

Aby uzyskać taką możliwość i korzystać ze wszystkich funkcji wyświetlanego składnika, należy zainstalować pakiet Microsoft Office XP lub uzyskać dostęp do licencji Office XP. Jeśli użytkownik pracuje w środowisku grupowym lub w firmie, może zwrócić się o pomoc do administratora sieci.

W trybie tylko do wyświetlenia można:

  • przeglądać dane,
  • drukować,
  • zaznaczać i przewijać,
  • używać hiperłączy,
  • zmieniać rozmiar składnika,
  • zaznaczać arkusze w składniku Arkusz kalkulacyjny,
  • rozwijać i zwijać elementy na liście tabeli przestawnej,
  • odświeżać dane na liście tabeli przestawnej,
  • używać poleceń Informacje, Pomoc i Odśwież. Nie dotyczy to tematów Pomocy odnoszących się do czynności interakcyjnych (takich jak formatowanie komórek, przeciąganie pól, sortowanie, filtrowanie i tak dalej).

Wszystkie polecenia z wyjątkiem poleceń Informacje, Pomoc i Odśwież są niedostępne w trybie tylko do wyświetlania.


Uzyskiwanie pomocy na temat wykresów — informacje

Część zawartości tego tematu może nie dotyczyć niektórych języków.

Uzyskiwanie pomocy w innych programach do projektowania

Podczas pracy w programie do projektowania można uzyskać pomoc dotyczącą projektowania wykresów w następujący sposób:

  • Pomoc programu do projektowania Aby uzyskać informacje dotyczące poleceń i funkcji dostępnych w programie do projektowania i przeznaczonych do pracy z wykresami, zobacz Pomoc programu do projektowania. Na przykład w programie Microsoft Access należy kliknąć Asystenta pakietu Office lub polecenie Microsoft Access — Pomoc [image].

    Program Microsoft Excel zawiera zarówno ogólną Pomoc dotyczącą zapisywania danych programu Excel przeznaczonych do wykorzystania na stronach sieci Web, jak i specyficzne informacje o zapisywaniu wykresów przeznaczonych do użycia na stronach sieci Web. Aby uzyskać dostęp do Pomocy tego typu w programie Excel, należy kliknąć Asystenta pakietu Office lub polecenie Microsoft Excel — Pomoc [image].

  • Pomoc w czasie projektowania wykresu Jeżeli podczas projektowania dostępne jest okno dialogowe Polecenia i opcje w innym programie do projektowania, to dostępne są również tematy Pomocy. Na wykresie utworzonym lub uaktywnionym w programie do projektowania, należy otworzyć okno dialogowe Polecenia i opcje, kliknąć kartę Ogólne, a następnie kliknąć przycisk Pomoc [image] albo kliknąć prawym przyciskiem myszy wykres, a następnie kliknąć polecenie Pomoc w menu skrótów.

Uzyskiwanie pomocy podczas pisania skryptów i programów używających wykresów w sieci Web

Skrypty i programy mogą być wykorzystane do automatyzowania wykresów. Można również dołączać wykresy do uruchamianych programów, innych niż przeglądarki sieci Web. Programy te można zaprojektować w środowisku programowania takim jak program Microsoft Visual Basic.

Pisanie skryptów Programy pakietu Microsoft Office zawierają Edytora skryptów Microsoft ułatwiającego pisanie skryptów. Na przykład można użyć Edytora skryptów w widoku Projekt strony dostępu do danych programu Microsoft Access, aby dostosować wykres. Aby uzyskać informacje o uruchamianiu Edytora skryptów, zobacz Pomoc używanego programu do projektowania pakietu Office. W Edytorze skryptów można wyświetlić dodatkową Pomoc dotyczącą używania jego funkcji i pisania skryptów.

Pomoc modelu obiektowego Aby łatwiej opracowywać program lub skrypt przeznaczony do pracy z listą wykresu można wyświetlić informacje dotyczące modelu obiektowego, właściwości i metod specyficznych dla wykresów. Pomoc modelu obiektowego jest instalowana podczas instalowania składników Microsoft Office Web Components, do których należy składnik Wykres. W zależności od wykorzystywanego programu do projektowania Pomoc może być wyświetlona w następujący sposób:

  • Pomoc w programie Microsoft Visual Basic W języku Visual Basic lub Visual Basic for Applications (VBA) można utworzyć odwołanie do biblioteki programu Microsoft Office Web Components. Dzięki temu można uzyskać dostęp do Pomocy poprzez przeglądarkę obiektów lub po zaznaczeniu słowa kluczowego i naciśnięciu klawisza F1. Aby uzyskać informacje o tworzeniu odwołań i używaniu Pomocy modelu obiektowego, zobacz Pomoc programu VBA.
  • Pomoc w innych środowiskach W przypadku używania innego środowiska projektowania, należy zlokalizować plik Pomocy Owcvba10.chm i kliknąć go dwukrotnie.

Uzyskiwanie i zapewnianie pomocy w przeglądarce

Pomoc dostępna w przeglądarce Użytkownicy posiadający program Microsoft Internet Explorer w wersji 4.01 lub nowszej i składniki sieci Microsoft Office Web Components automatycznie uzyskują dostęp do Pomocy ogólnej dotyczącej wykresów. Jest to Pomoc dostępna w czasie wykonywania, niezależna od pomocy, którą można uzyskać za pomocą menu Pomoc w przeglądarce.

Pomoc dostępna na wykresie Tematy pomocy wykresu dostępne w czasie wykonywania zawierają ogólne informacje przeznaczone dla wszystkich użytkowników i dotyczące używania wykresów w przeglądarce — takie jak sposób korzystania z paska narzędzi i menu kontekstowego czy sposób pracy z listą pól i polami po utworzeniu wykresu na podstawie listy tabeli przestawnej albo tabeli lub kwerendy bazy danych.

Opisywana Pomoc nie obejmuje informacji dotyczących pracy z oknem dialogowym Polecenia i opcje, więc nie zawiera tych samych tematów Pomocy, które są właśnie wyświetlane. Ze względu na umiejętności użytkowników i wykonywany przez nich typ pracy przydatne może być uzupełnienie Pomocy dostępnej w czasie wykonywania niestandardowymi instrukcjami dotyczącymi wykresu na stronie sieci Web albo hiperłączem do zawierającej informacje strony sieci Web.

Inne składniki Microsoft Office Web Components, takie jak Tabela przestawna czy Arkusz kalkulacyjny mają własną, oddzielną Pomoc dostępną w przeglądarce.

Aby zobaczyć Pomoc dostępną w przeglądarce, należy utworzyć wykres na stronie sieci Web, otworzyć stronę sieci Web w programie Internet Explorer, kliknąć wykres prawym przyciskiem myszy, a następnie kliknąć polecenie Pomoc [image] w menu skrótów. Okno Pomocy umożliwia przeglądanie spisu treści i wyszukanie tekstu tematów. Asystent pakietu Office jest niedostępny w przeglądarce i nie może udzielić odpowiedzi na pytania.


Klawisze skrótów

Aby uzyskać informacje na temat uaktywniania i dezaktywowania wykresu za pomocą klawiatury, zobacz Pomoc programu do projektowania.

Klawisze do zaznaczania elementów na wykresie

STRZAŁKA W PRAWO
Zaznacza następny element wykresu
STRZAŁKA W LEWO
Zaznacza poprzedni element wykresu
STRZAŁKA W DÓŁ
Zaznacza następną grupę elementów
STRZAŁKA W GÓRĘ
Zaznacza poprzednią grupę elementów

Klawisze do pracy z poleceniami i opcjami

ALT+ENTER
Wyświetla okno dialogowe Polecenia i opcje
ALT+F4
Zamyka okno dialogowe Polecenia i opcje
Klawisz TAB
Jeśli okno dialogowe Polecenia i opcje jest aktywne, zaznacza następny element na aktywnej karcie
Strzałka w prawo
Jeśli karta w oknie dialogowym Polecenia i opcje jest aktywna, zaznacza następną kartę
Strzałka w lewo
Jeśli karta w oknie dialogowym Polecenia i opcje jest aktywna, zaznacza poprzednią kartę
Strzałka w dół
Wyświetla listę lub paletę, jeśli przycisk zawierający listę lub paletę jest zaznaczony
SHIFT+F10
Wyświetla menu skrótów
Podkreślona litera
Powoduje wykonanie polecenia menu skrótów
ESC
Zamyka menu skrótów bez wykonania polecenia
CTRL+Z
Cofa akcję wykonaną na wykresie
DELETE
Usuwa aktualnie zaznaczony element

Klawisze do pracy z arkuszem danych

ENTER
Wprowadza dane i przenosi zaznaczenie komórki o jedną komórkę w dół
Klawisz TAB
Wprowadza dane i przenosi zaznaczenie komórki o jedną komórkę w prawą stronę
Klawisze strzałek
Przenoszą o jedną komórkę w górę, w dół, w prawo lub w lewo

Klawisze do pracy z polami

ALT+STRZAŁKA W DÓŁ
Otwiera listę aktualnie zaznaczonego pola
Klawisz TAB
Przechodzi kolejno do ostatnio wybranego elementu, przycisku OK i przycisku Anuluj na liście rozwijanej pola
Klawisze strzałek
Przechodzą do następnego elementu na liście rozwijanej pola
SPACJA
Zaznacza lub czyści pole wyboru bieżącego elementu na liście rozwijanej pola
ENTER
Zamyka listę rozwijaną pola i stosuje wszystkie wprowadzone zmiany
ESC
Zamyka listę rozwijaną pola bez zastosowania zmian

Klawisze do pracy z listą pól

CTRL+L
Wyświetla listę pól lub uaktywnia ją, jeżeli jest już wyświetlona
Klawisze strzałek
Przechodzą do następnego elementu na liście pól
SHIFT+STRZAŁKA W GÓRĘ
Przechodzi do poprzedniego elementu i dołącza go do zaznaczenia
SHIFT+STRZAŁKA W DÓŁ
Przechodzi do następnego elementu i dołącza go do zaznaczenia
CTRL+STRZAŁKA W GÓRĘ
Przechodzi do poprzedniego elementu bez dołączania go do zaznaczenia
CTRL+STRZAŁKA W DÓŁ
Przechodzi do następnego elementu bez dołączania go do zaznaczenia
CTRL+SPACJA
Usuwa element z zaznaczenia, jeśli element, który ma fokus, jest dołączony do zaznaczenia i vice versa
ZNAK PLUS (klawiatura numeryczna)
Rozwija bieżący element na liście pól w celu wyświetlenia jego zawartości albo rozwija sumy w celu wyświetlenia dostępnych pól sum.
ZNAK MINUS (klawiatura numeryczna)
Zwija bieżący element na liście pól w celu ukrycia jego zawartości albo zwija sumy w celu ukrycia dostępnych pól sum
Klawisz TAB
Przechodzi kolejno do ostatnio zaznaczonego elementu, przycisku Dodaj do i listy obok przycisku Dodaj do na liście pól
ALT+STRZAŁKA W DÓŁ
Otwiera listę rozwijaną obok przycisku Dodaj do na liście pól. Należy użyć klawiszy strzałek, aby przejść do następnego elementu na liście, a następnie nacisnąć klawisz ENTER, aby go zaznaczyć
ENTER
Dodaje pole wyróżnione na liście pól do obszaru listy tabeli przestawnej wyświetlonego na liście Dodaj do
ALT+F4
Zamyka listę pól

Klawisze do pracy z Pomocą

Klawisze do pracy w oknie Pomocy

F6
Przełącza między okienkiem nawigacji i okienkiem tematu
ALT+O
Wyświetla menu Opcje, aby udostępnić każde polecenie na pasku narzędzi Pomoc
ALT+SPACJA
Wyświetla menu Sterowanie programu
ALT+F4
Zamyka okno Pomocy

Klawisze do pracy w okienku nawigacji

CTRL+TAB
Przechodzi do innej karty
ENTER
Otwiera lub zamyka zaznaczoną książkę albo otwiera zaznaczony temat Pomocy
STRZAŁKA W DÓŁ
Zaznacza następną książkę lub temat Pomocy
STRZAŁKA W GÓRĘ
Zaznacza poprzednią książkę lub temat Pomocy
SHIFT+F10
Wyświetla menu skrótów

Klawisze do pracy w okienku tematu

ALT+STRZAŁKA W PRAWO
Przechodzi dalej do poprzednio przeglądanego tematu Pomocy
ALT+STRZAŁKA W LEWO
Przechodzi wstecz do poprzednio przeglądanego tematu Pomocy
Klawisz TAB
Zaznacza następny tekst ukryty lub hiperłącze albo przycisk Pokaż wszystko lub Ukryj wszystko na początku tematu
SHIFT+TAB
Zaznacza poprzedni tekst ukryty lub hiperłącze
ENTER
Powoduje wykonanie akcji zaznaczonego przycisku Pokaż wszystko, Ukryj wszystko, tekstu ukrytego lub hiperłącza
STRZAŁKA W GÓRĘ albo STRZAŁKA W DÓŁ
Przewija w kierunku początku albo końca tematu Pomocy
PAGE UP albo PAGE DOWN
Przewija w kierunku początku albo końca tematu Pomocy w większych przyrostach
HOME albo END
Przechodzi do początku albo końca tematu Pomocy
CTRL+P
Drukuje bieżący temat Pomocy
CTRL+A
Zaznacza cały temat Pomocy
CTRL+C
Kopiuje zaznaczenie do Schowka
SHIFT+F10
Wyświetla menu skrótów


Narzędzia, polecenia i lista pól wykresu — informacje

Pasek narzędzi

Pasek narzędzi w górnej części wykresu zawiera zestaw poleceń używanych do pracy z wyświetlanym wykresem i danymi. Na przykład można używać paska narzędzi do zmieniania typu wykresu, dodawania lub usuwania legendy, zmieniania danych serii lub kategorii w celu odzwierciedlenia danych w wierszach lub kolumnach itd. Pasek narzędzi jest najbardziej przydatny, jeśli wykres utworzono na podstawie danych pochodzących z listy tabeli przestawnej, tabeli lub kwerendy bazy danych, a trzeba posortować, filtrować lub zmienić sposób wyświetlania danych na wykresie.

Paska narzędzi można używać podczas projektowania wykresu, a użytkownicy mogą z niego korzystać podczas pracy z wykresem w czasie uruchomienia (na przykład podczas wyświetlania wykresu w przeglądarce). Aby zobaczyć nazwę polecenia odpowiadającą danemu przyciskowi, należy przytrzymać na nim wskaźnik myszy.

Okno dialogowe Polecenia i opcje

Okno dialogowe Polecenia i opcje zawiera polecenia służące do zmiany opcji formatowania, zaznaczania części wykresu, grupowania i rozgrupowywania serii w celu łączenia wykresów itd. W oknie dialogowym znajdują się również niektóre polecenia, które nie występują na pasku narzędzi lub w menu skrótów. Aby wyświetlić okno dialogowe, można kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi albo kliknąć wykres prawym przyciskiem myszy, a następnie kliknąć polecenie Polecenia i opcje w menu skrótów.

Polecenia i właściwości dostępne w oknie dialogowym Polecenia i opcje są rozproszone na kilku kartach, takich jak karta Ogólne (gdzie można zaznaczać części wykresu, dodać lub usunąć tytuł wykresu lub legendy, a także zmienić niektóre opcje formatowania wykresu). Pozostałe karty są wyświetlane w zależności od zaznaczonej części wykresu. Na przykład po zaznaczeniu serii danych wyświetlone będą karty związane z seriami danych, takie jak karta Obramowanie/Wypełnienie, Typ czy Format warunkowy. Po zaznaczeniu osi będą wyświetlane karty Format, Linia/Znacznik, Oś oraz Skala. Jeśli nie można zlokalizować poszukiwanego polecenia, to należy się upewnić, że zaznaczono właściwy, odpowiadający temu poleceniu element na wykresie.

Lista pól

Lista pól jest dostępna z paska narzędzi wykresu, jeśli wykres utworzono na podstawie danych pochodzących z bazy danych lub z listy tabeli przestawnej. Należy używać listy pól do przeglądania listy pól dostępnych w danych źródłowych i dodawania pól do obszarów kategorii, serii, filtrów i danych na wykresie. Niepogrubione pola na liście pól są dostępne, ale nie zostały jeszcze wyświetlone na wykresie. Pola, których nazwy są wyświetlone pogrubioną czcionką, są już wyświetlone na wykresie. Aby pokazać lub ukryć dodatkowe pola, można przewijać i klikać wskaźniki rozwijania (pola Pole plus i Pole minus).

Menu skrótów

Po kliknięciu aktywnego wykresu prawym przyciskiem myszy wyświetlane jest menu skrótów zawierające polecenia wyświetlenia lub ukrycia paska narzędzi, okna dialogowego Polecenia i opcje oraz — jeśli wykres utworzono na podstawie listy tabeli przestawnej lub danych z bazy danych — listy pól i obszarów upuszczania. Menu skrótów zawiera również polecenie Dane, które umożliwia zmienianie danych źródłowych wykresu.

Dostęp w czasie uruchomienia do paska narzędzi, listy pól, menu skrótów i okna dialogowego Polecenia i opcje

Okno dialogowe Polecenia i opcje domyślnie jest niedostępne podczas uruchomienia. Niedostępna jest również pomoc dotycząca okna dialogowego Polecenia i opcje. Można włączyć okno dialogowe Polecenia i opcje w czasie uruchamiania, ale trzeba opracować instrukcje używania go na stronie sieci Web.

Pasek narzędzi jest dostępny w czasie uruchomienia, ale tylko wówczas, jeśli użytkownicy go zaznaczą lub zostanie włączona opcja domyślnego wyświetlania go na wykresie. Lista pól jest dostępna, jeśli wykres utworzono na podstawie danych pochodzących z bazy danych lub listy tabeli przestawnej i włączono ją w oknie dialogowym Polecenia i opcje.

Menu skrótów jest dostępne, ale nie można go zastosować do poleceń niedostępnych w czasie uruchamiania.


Pokazywanie lub ukrywanie paska narzędzi wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij wykres prawym przyciskiem myszy, a następnie kliknij polecenie Pasek narzędzi w menu skrótów.


Pokazywanie lub ukrywanie okna dialogowego Polecenia i opcje

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Aby wyświetlić okno dialogowe Polecenia i opcje, kliknij wykres prawym przyciskiem myszy, a następnie kliknij polecenie Polecenia i opcje w menu skrótów.
    • Aby ukryć okno dialogowe Polecenia i opcje kliknij przycisk Zamknij [image] w górnym prawym rogu okna dialogowego.


Używanie okna dialogowego Polecenia i opcje

Jeżeli okno dialogowe Polecenia i opcje pozostanie wyświetlone podczas zaznaczania różnych części wykresu, to dostępne karty i ich zawartość będą się zmieniać, aby odzwierciedlić bieżące zaznaczenie.

  1. Wyświetl okno dialogowe Polecenia i opcje, klikając wykres prawym przyciskiem myszy, a następnie w menu skrótów klikając polecenie Polecenia i opcje.
  2. Zaznacz część wykresu, którą chcesz zmodyfikować, klikając raz, aby zaznaczyć grupę (taką jak seria danych), a następnie klikając drugi raz, aby zaznaczyć pojedynczy element w grupie (taki jak znacznik danych w obrębie serii). Można również wybrać część, którą chcesz zmodyfikować, z listy Zaznacz znajdującej się na karcie Ogólne okna dialogowego Polecenia i opcje.
  3. W oknie dialogowym Polecenia i opcje kliknij kartę zawierającą opcje, które chcesz zmodyfikować, a następnie wprowadź zmiany.
  4. Jeśli karty opcji, które chcesz zmodyfikować, nie są wyświetlone, to trzeba zaznaczyć inny element na wykresie.


Pokazywanie lub ukrywanie obszarów upuszczania

Po ukryciu obszarów upuszczania nie można dodawać ani przeciągać pól na wykresie.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij wykres prawym przyciskiem myszy, a następnie kliknij polecenie Obszary upuszczania w menu skrótów.

Uwaga Element menu Obszary upuszczania jest dostępny pod warunkiem, że wykres utworzono na podstawie danych pochodzących z bazy danych lub z listy tabeli przestawnej.


Elementy wykresu

Serie, kategorie i reprezentacja danych

Przykład elementów wykresu reprezentujących dane

1 Linia siatki

2 Seria danych

3 Znacznik danych

4 Kategoria

5 Obszar kreślenia

6 Klucz legendy

6 Nazwa serii

6 Legenda

Linia siatki Linie, które można dodać do wykresu, aby ułatwić przeglądanie i szacowanie danych. Linie siatki rozciągają się od znaczników osi i przechodzą poprzez obszar kreślenia.

Serie danych, nazwa serii (pozycja legendy) Grupa powiązanych punktów danych wykreślonych na wykresie. Każda seria danych ma unikatowy kolor lub deseń i jest reprezentowana w legendzie przez klucz legendy i nazwę serii (wpis legendy). W poprzednim przykładzie wykresu seriami danych są Planowane i Rzeczywiste. Na większości wykresów można wykreślić jedną lub kilka serii danych.

Znacznik danych Służy do reprezentowania punktu danych, który jest pojedynczą wartością wykreśloną na wykresie. Powiązane punkty danych stanowią serię danych. Przykłady punktów danych to słupki, kropki i wycinki.

Kategoria Grupa powiązanych punktów danych, po jednym punkcie z każdej serii danych wykresu. Na większości wykresów kategorie są wykreślane wzdłuż osi kategorii (x), która jest zwykle pozioma. Jednak na niektórych wykresach, na przykład na wykresie słupkowym, oś kategorii (x) jest pionowa. W poprzednim przykładzie wykresu Kw1, Kw2, Kw3 i Kw4 są kategoriami, przy czym każda z nich jest utworzona z jednego punktu z serii Prognozowane i jednego z serii Rzeczywiste.

Obszar kreślenia Obszar wykresu ograniczony przez osie i zawierający wszystkie serie danych.

Klucz legendy Obrazy w legendzie pokazujące desenie i kolory przypisane do serii danych lub kategorii wykresu. Klucze legendy widnieją po lewej stronie pozycji legendy.

Legenda Klucz wyjaśniający desenie lub kolory przypisane do serii danych lub kategorii na wykresie.

Osie

Osie na wykresie

1 Tytuł osi wartości (y)

2 Etykiety znaczników osi wartości (y)

3 Oś wartości (y)

4 Linia siatki

5 Pomocniczy znacznik osi

5 Tytuł osi kategorii

6 Etykiety znaczników osi kategorii (x)

6 Oś kategorii (x)

Tytuł osi wartości (y) Tytuł, który jest zwykle używany do opisu wartości przedstawianej na tej osi.

Etykiety znaczników osi wartości (y) Nazywane są również etykietami osi wartości. Opisują wartości pomiaru na osi wartości.

Oś wartości (y) Linia ograniczająca jeden brzeg obszaru kreślenia, stanowiąca układ odniesienia dla pomiarów i porównań na wykresie. W przypadku większości wykresów wartości danych są wykreślane wzdłuż osi wartości (y), która jest zwykle pionowa. Jednak w niektórych wykresach, na przykład na wykresie słupkowym, oś wartości (y) jest pozioma. Na niektórych wykresach wartości danych są wykreślane wzdłuż obu osi, na przykład na wykresie punktowym (xy).

Linia siatki Linie, które można dodać do wykresu, aby ułatwić przeglądanie i szacowanie danych. Linie siatki rozciągają się od znaczników osi na cały obszar kreślenia.

Główne i pomocnicze znaczniki osi Krótkie kreski miary przechodzące przez oś, podobne do podziałki linijki. Główne znaczniki osi pojawiają się przy wszystkich głównych jednostkach miary na skali osi, a pomocnicze znaczniki osi przy każdej pomocniczej jednostce miary. Obydwa typy znaczników mogą być umieszczane wewnątrz lub na zewnątrz osi, lub mogą ją przecinać.

Tytuł osi kategorii (x) Tytuł, który jest zwykle używany do opisu wartości wykreślanej na osi kategorii.

Etykiety znaczników osi kategorii (x) Znane są również jako etykiety kategorii. Pokazują nazwy kategorii na osi kategorii.

Oś kategorii (x) Linia ograniczająca jeden brzeg obszaru kreślenia, stanowiąca układ odniesienia dla pomiarów i porównań na wykresie. Kategorie to grupy punktów danych, po jednym punkcie z każdej serii danych wykresu. W przypadku większości wykresów kategorie są wykreślane wzdłuż osi kategorii (x), która jest zwykle pozioma. Jednak na niektórych wykresach, na przykład na wykresie słupkowym, oś kategorii (x) jest pionowa. Niektóre wykresy, na przykład wykres punktowy (xy), nie mają osi kategorii.

Tytuły i etykiety

Tytuły i etykiety wykresu

1 Tytuł obszaru roboczego wykresu (tytuł wszystkich wykresów w obszarze roboczym)

2 Tytuł wykresu (tytuł pojedynczego wykresu)

3 Tytuł osi wartości

4 Tytuł osi kategorii

5 Etykieta kategorii

6 Etykieta danych

6 Etykieta osi wartości

6 Legenda obszaru roboczego wykresu (legenda dla wszystkich wykresów w obszarze roboczym)

9 Legenda wykresu (legenda pojedynczego wykresu)

Tytuł obszaru roboczego wykresu Tytuł opisujący wszystkie wykresy, jeśli w obszarze roboczym jest kilka wykresów. Może być umieszczony powyżej lub poniżej wykresu albo na lewo lub na prawo od wykresu.

Tytuł wykresu Tytuł opisujący pojedynczy wykres. Może być umieszczony powyżej lub poniżej wykresu albo na lewo lub na prawo od wykresu.

Tytuł osi wartości Tytuł używany zazwyczaj do opisania wartości mierzonej na osi wartości.

Tytuł osi kategorii Tytuł używany zazwyczaj do opisania wartości mierzonej na osi kategorii.

Etykieta kategorii Znana również jako etykieta znaczników osi. Etykiety pokazują nazwy kategorii na osi kategorii. Kategoria jest grupą powiązanych punktów danych, po jednym punkcie danych z każdej serii danych wykresu.

Etykieta danych Etykieta udostępniająca dodatkowe informacje o znaczniku danych reprezentującym jeden punkt danych lub wartość. W zależności od typu wykresu w etykietach danych mogą być wyświetlane wartości, nazwy serii danych lub kategorii, procenty lub ich kombinacje.

Etykieta osi wartości Znana również jako etykieta znaczników osi. Opisuje wartości pomiaru na osi wartości.

Legenda obszaru roboczego wykresu Klucz wyjaśniający desenie lub kolory przypisane do serii danych lub kategorii na wszystkich wykresach w obszarze roboczym multiwykresu.

Legenda wykresu Klucz wyjaśniający desenie lub kolory przypisane do serii danych lub kategorii na pojedynczym wykresie.

Pola

Wykres utworzony na podstawie bazy danych lub listy tabeli przestawnej zawiera pola, które można przenosić, filtrować i sortować, tak jak listę tabeli przestawnej.

Wykres z polami

1 Pole filtru

2 Pole multiwykresu

3 Pole danych

4 Pole serii

4 Pole kategorii

Pole filtru Pole używane do filtrowania danych według określonych elementów. W poprzednim przykładzie w polu filtru Rok wyświetlane są dane obejmujące wszystkie lata, w których rejestrowano dane. Aby wyświetlić dane dla pojedynczego roku, można kliknąć strzałkę obok pola Rok i wybrać rok.

Pole multiwykresu Pole używane do wyświetlania oddzielnych wykresów dla każdego elementu w polu. W przykładzie pole Sprzedawca jest filtrowane, aby pokazać dwóch sprzedawców: Dodsworth i Suyama. Ponieważ pole znajduje się w obszarze multiwykresu, dla każdego z nich są wyświetlane dwa oddzielne wykresy.

Pole danych Pole z podstawowych danych źródłowych, z którego pobierane są wartości do porównywania lub pomiaru. W podanym przykładzie pole Suma sprzedaży jest polem danych podsumowującym wielkości sprzedaży według regionów dla każdego typu produktu. Znacznik danych pierwszej kategorii na wykresie dla sprzedawcy Dodsworth (E) osiąga wartość nieco ponad 200 na osi wartości (y). Ta wartość jest sumą sprzedaży produktów osiągniętą przez sprzedawcę Dodsworth w regionie Wschodnim. W zależności od źródła danych używanego w przypadku raportu można zmienić funkcję podsumowania z funkcji Suma na funkcję Średnia, Maks, Min lub inne obliczenie.

Pole serii Pole przypisywane do orientacji serii na wykresie. Elementy w polu stanowią indywidualne serie danych. W podanym przykładzie pole Typ jest polem serii.

Pole kategorii Pole z danych źródłowych przypisane do orientacji kategorii na wykresie. Pole kategorii dostarcza indywidualnych kategorii, dla których wykreślane są punkty danych. W podanym przykładzie pole Region jest polem kategorii.


Przykłady typów wykresów

Wykres warstwowy

Wykres warstwowy służy do wyrażenia przebiegu zmiany w czasie. Za pomocą wyświetlania sumy wykreślonych wartości, na wykresie warstwowym pokazana jest także zależność między poszczególnymi częściami i całością.

W powyższym przykładzie wykres warstwowy wyraża wzrost sprzedaży w stanie Waszyngton i ilustruje wkład każdego stanu w całkowitą wartość sprzedaży.

Wykres kolumnowy

Wykres kolumnowy służy do pokazania zmiany danych w czasie lub ilustruje porównania między elementami. Aby podkreślić zmiany w czasie, kategorie są zorganizowane w poziomie, a wartości w pionie.

Skumulowane wykresy kolumnowe pokazują zależności zachodzące między poszczególnymi elementami i całością.

Skumulowany wykres kolumnowy

Wykres słupkowy

Wykres słupkowy służy do ilustrowania porównania między poszczególnymi elementami. Aby bardziej skupić uwagę na porównywanych wartościach, a w mniejszym stopniu na czasie, kategorie są zorganizowane w pionie, a wartości w poziomie.

Skumulowane wykresy słupkowe pokazują zależności zachodzące między poszczególnymi elementami i całością.

Skumulowany wykres słupkowy

Wykres liniowy

Wykres liniowy służy do pokazania trendów danych w równych interwałach.

Wygładzony wykres liniowy

Wygładzony wykres liniowy pokazuje trendy danych w równych interwałach, tak wygładzone, aby pokazać szacowane dane pomiędzy interwałami.

Wygładzony wykres liniowy

Wykres kołowy

Wykres kołowy służy do pokazywania proporcjonalnego rozmiaru elementów tworzących serię danych w odniesieniu do sumy elementów. Wykres taki pokazuje zawsze tylko jedną serię danych i jest używany, gdy trzeba zwrócić uwagę na jeden istotny element.

Można również utworzyć skumulowany wykres kołowy, to znaczy wykres kołowy zawierający więcej niż jedną serię.

Skumulowany wykres kołowy

Wykres pierścieniowy

Podobnie jak wykres kołowy, wykres pierścieniowy służy do pokazywania relacji między elementami a całością, ale może zawierać więcej niż jedną serię danych, ponieważ tworzą go pierścienie, a nie wycinki. Każdy pierścień wykresu pierścieniowego reprezentuje serię danych.

Wykres giełdowy

Są dwa typy wykresów giełdowych, często używane do ilustrowania cen akcji - wykres najwyż-najniż-otw-zamk oraz wykres najwyż-najniż-zamk. Te wykresy mogą być również używane do ilustrowania danych naukowych, na przykład do wskazania najwyższych, najniższych i średnich temperatur. Wykres w poniższym przykładzie to wykres typu najwyż-najniż-zamk.

Dane do wykreślenia i wykres giełdowy

Wykres punktowy (xy)

Wykres punktowy (xy) służy do pokazywania zależności występujących między wartościami liczbowymi w kilku seriach danych albo do wykreślania dwóch grup liczb w postaci jednej serii współrzędnych xy. Tego rodzaju wykresy pokazują zmienne interwały — lub grupy — danych i są używane głównie w przypadku danych naukowych.

Podczas rozmieszczania danych należy umieścić wartości x w jednym wierszu lub kolumnie a odpowiadające im wartości y w sąsiednim wierszu lub kolumnie w rozmieszczeniu x-y x-y.

Wykres punktowy (xy)

Wykres bąbelkowy

Wykres bąbelkowy to typ wykresu punktowego(xy). Rozmiar znacznika danych wskazuje wartość trzeciej zmiennej.

Aby rozmieścić dane, należy umieścić wartości x w jednym wierszu lub kolumnie, a następnie wprowadzić odpowiadające im wartości y i rozmiary bąbelków w sąsiednich wierszach lub kolumnach.

Dane do wykreślenia

Wykres radarowy

W wykresie radarowym każda kategoria ma własną oś wartości wybiegającą z centralnego punktu. Wartości tej samej serii są połączone liniami.

Wykres radarowy służy do porównywania zagregowanych wartości wielu serii danych. Na powyższym wykresie seria danych obejmująca największy obszar (seria Gatunek A) reprezentuje najwyższą zawartość witamin.

Wykres polarny

Wykres polarny ilustruje związek między kątami a odległością. W powyższym przykładzie wykres pokazuje kąty nachylenia dla dwóch wysokości anteny radiowej.


Tworzenie wykresu

Poszczególne kroki tworzenia wykresu zależą od programu używanego do projektowania strony sieci Web. Aby uzyskać więcej informacji, zobacz Pomoc programu do projektowania. Jeżeli Pomoc nie zawiera procedury dotyczącej tworzenia takich składników, jak wykresy, wykonaj następujące kroki:

  1. W programie do projektowania otwórz lub utwórz bazę danych, projekt lub stronę sieci Web z danymi, które chcesz wykorzystać na wykresie.
  2. Uaktywnij stronę, na której chcesz umieścić wykres.
  3. Korzystając z zawartej w programie do projektowania procedury dodawania formantu do strony sieci Web, określ lokalizację i początkowy rozmiar wykresu na stronie sieci Web.
  4. Jeśli okno dialogowe Polecenia i opcje nie jest wyświetlone, kliknij wykres, aby je wyświetlić.
  5. Na karcie Źródło danych określ dane, których chcesz użyć na wykresie, zaznaczając opcje Dane wpisane do arkusza danych, Dane z tabeli lub kwerendy bazy danych lub Dane z następującego elementu strony sieci Web.
  6. Po zaznaczeniu opcji Dane z następującego elementu strony sieci Web zaznacz również element strony sieci Web (na przykład arkusz kalkulacyjny, listę tabeli przestawnej albo formant źródła danych), którego chcesz użyć na liście. Tylko elementy znajdujące się na tej stronie sieci Web, na której tworzony jest wykres, będą pokazane na liście.
  7. Określ ustawienia danych dla jednej z poniższych opcji:

    Dane wpisane do arkusza danych

    1. W obszarze Ustaw szczegóły typu danych kliknij element Arkusz danych.
    2. W arkuszu danych zaznacz komórkę, a następnie wprowadź dane z każdej serii w komórkach kolumn oznaczonych etykietą Serie n albo z każdej kategorii w wierszach oznaczonych etykietą Kategoria n.
      • Można wprowadzić etykiety kategorii lub serii w pierwszej kolumnie lub w pierwszym wierszu arkusza danych.
      • Wprowadzając dane, naciśnij klawisz ENTER, aby przenieść się w dół w kolumnie albo klawisz TAB, aby przenieść się z kolumny do kolumny. Naciśnij klawisz DELETE, aby usunąć dane. Wiersze i kolumny będą automatycznie rozwijane lub zwijane, stosownie do mniejszych lub większych ilości danych.
      • Do reprezentowania wprowadzonych danych na wykresie automatycznie jest używany domyślny typ wykresu kolumnowego.
      • Aby serie znajdowały się w wierszach, a kategorie w kolumnach, kliknij przycisk Według wierszy — Według kolumn [image].

    Dane z tabeli lub kwerendy bazy danych

    1. W obszarze Ustaw szczegóły typu danych kliknij opcję Połączenie.
    2. Wprowadź ciąg połączenia w polu Połączenie lub kliknij przycisk Edytuj, aby przeglądać lub wprowadzić informacje o źródle danych.
    3. Zależnie od programu do projektowania, kliknięcie przycisku Edytuj wyświetla okno dialogowe Wybieranie źródła danych lub okno dialogowe Właściwości łącza danych.

      Okno dialogowe Wybieranie źródła danych

      1. Zlokalizuj źródło danych, którego chcesz użyć, w polu Szukaj w i kliknij je dwukrotnie na liście.
      2. Jeśli źródło danych, którego chcesz użyć, jest niedostępne, kliknij przycisk Nowe źródło i postępuj według instrukcji wyświetlanych w oknie Kreator łączenia danych, aby utworzyć nowy plik połączenia danych.

      Okno dialogowe Właściwości łącza danych

      • Wprowadź informacje o połączeniu źródła danych na karcie Połączenie. Aby uzyskać pomoc dotyczącą opcji, kliknij przycisk Pomoc u dołu okna dialogowego.
    4. Zaznacz opcję Nazwa członka danych, tabeli, widoku lub modułu i wybierz nazwę członka danych, tabeli, widoku lub modułu z listy albo zaznacz opcję Tekst polecenia lub SQL i wpisz żądany ciąg połączenia.
    5. W obszarze Kreślenie szczegółów wybierz, czy serie mają się znajdować w wierszach czy w kolumnach, klikając przycisk Serie według wierszy/kolumn [image].
    6. Chcąc skorzystać z bezpośrednich wartości rekordów danych, na przykład w przypadku utworzenia kwerendy do obliczania sum na serwerze, których wykres ma używać zamiast sum obliczonych na komputerze klienckim, zaznacz pole wyboru Kreśl rekordy szczegółowe.
    7. Dodawanie danych z listy pól do obszarów upuszczania wykresu

      Jak?

      1. Na pasku narzędzi wykresu kliknij przycisk Lista pól [image].
      2. Użyj pasków przewijania i wskaźników rozwijania (pola Pole plus i Pole minus), aby znaleźć pole, które chcesz dodać do wykresu.
      3. Kliknij pole i przeciągnij je do odpowiedniego obszaru upuszczania na wykresie: obszaru Upuść pola serii tutaj, Upuść pola kategorii tutaj, Upuść pola danych tutaj lub Upuść pola filtru tutaj.

        Można dodać wiele pól do każdej z lokalizacji.

      Uwaga Można przeciągać pola albo na liście pól zaznaczyć obszar, do którego ma być dodane pole (obszary są wyświetlane na końcu listy pól), a następnie kliknąć przycisk Dodaj do. Jeśli przycisk Dodaj do jest niedostępny po zaznaczeniu żądanego obszaru, to zaznaczone pole może być niedostępne do użycia jako pole kategorii, serii, danych albo filtru.

    Dane z elementu strony sieci Web: arkusz kalkulacyjny

    1. W obszarze Ustaw szczegóły typu danych kliknij opcję Zakresy.
    2. Wykonaj jedną z następujących czynności:

      Określanie wszystkich danych naraz

      1. W obszarze Ustawianie zakresów w jednym kroku, w polu Zakres danych wprowadź rozdzielone dwukropkiem (:) odwołania do zakresu danych, który chcesz wykreślić. Na przykład aby użyć danych w ciągłym zakresie od komórki A1 do komórki G5 w arkuszu kalkulacyjnym, wpisz ciąg A1:G5 w polu Zakres danych.
      2. Obok pola Serie w kliknij przycisk Wiersze lub Kolumny, aby określić lokalizację danych serii.
      3. Kliknij przycisk OK.

      Określanie jednej serii danych naraz

      1. W obszarze Serie kliknij przycisk Dodaj.
      2. Aby nadać serii opisową nazwę, zamień nazwę domyślną w polu Nazwa serii na żądaną nazwę.
      3. W polu Etykiety kategorii wpisz odwołania do komórek etykiet kategorii tej serii. Na przykład, jeśli dodawana jest seria z wiersza A2:G2, a etykiety kategorii są w komórkach od A1 do G1, wpisz ciąg A1:G1.
      4. W polu Wartości wpisz odwołanie do zakresu wartości tej serii. Na przykład, jeśli dane serii są w komórkach od A2 do G2 w arkuszu kalkulacyjnym, to wpisz ciąg A2:G2.
      5. Powtórz krok w przypadku każdej serii danych, którą chcesz dodać.

    Dane z elementu strony sieci Web: lista tabeli przestawnej
    1. W obszarze Ustaw szczegóły typu danych kliknij opcję Szczegóły przestawne.

      Ponieważ wykres używa danych połączonych na liście tabeli przestawnej, opcje Połączenia są niedostępne.

    2. W obszarze Kreślenie szczegółów wybierz, czy serie mają się znajdować w wierszach czy w kolumnach, klikając przycisk Serie według wierszy/kolumn [image].
    3. Chcąc skorzystać z bezpośrednich wartości rekordów danych, na przykład w przypadku utworzenia kwerendy do obliczania sum na serwerze, których wykres ma używać zamiast sum obliczonych na komputerze klienckim, zaznacz pole wyboru Kreśl rekordy szczegółowe.
    4. Można także dodawać, zmieniać lub usuwać pola na wykresie, klikając przycisk Lista pól [image] na pasku narzędzi wykresu.

    Dane z elementu strony sieci Web: formant źródła danych

    1. W obszarze Ustaw szczegóły typu danych kliknij opcję Szczegóły źródła danych.
    2. Na liście Nazwa członka danych, tabeli, widoku lub modułu kliknij element zawierający dane, których chcesz użyć na wykresie.
    3. W obszarze Kreślenie szczegółów wybierz, czy serie mają być w wierszach czy w kolumnach, klikając przycisk Serie według wierszy/kolumn [image].
    4. Chcąc skorzystać z bezpośrednich wartości rekordów danych, na przykład w przypadku utworzenia kwerendy do obliczania sum na serwerze, których wykres ma używać zamiast sum obliczonych na komputerze klienckim, zaznacz pole wyboru Kreśl rekordy szczegółowe.
    5. Można także dodawać, zmieniać lub usuwać pola na wykresie, klikając przycisk Lista pól [image] na pasku narzędzi wykresu.
  8. Kliknij kartę Typ, kliknij na liście typ wykresu, którego chcesz użyć, a następnie kliknij żądany podtyp wykresu wyświetlany po prawej stronie.
  9. Kliknij wykres lub element wykresu, aby opcje w oknie dialogowym Polecenia i opcje stały się dostępne. W oknie dialogowym będą wyświetlane różne opcje, w zależności od zaznaczonego elementu wykresu. Na przykład po zaznaczeniu całego wykresu dostępna będzie karta Ogólne (na której można dodać legendę lub etykiety danych albo wprowadzić inne zmiany uzależnione od typu wykresu). W przypadku zaznaczenia osi będą wyświetlane karty Format, Linia/Znacznik, Oś oraz Skala.


Dane źródłowe wykresów — informacje

Podczas tworzenia wykresu można korzystać z istniejących danych albo dostarczyć je podczas tworzenia. Jeśli wykres opiera się na istniejących danych, to dane źródłowe muszą być udostępnione, a czasami muszą znajdować się na tej samej stronie sieci Web, na której ma być umieszczony wykres.

Wykresy mogą wykorzystywać dane pochodzące z następujących źródeł.

Arkusz danych wykresu

Aby wprowadzić dane w czasie tworzenia wykresu, należy użyć arkusza danych wykresu. Arkusz danych składa się z wierszy i kolumn, a użytkownik może w nim kopiować i wklejać informacje. Po wprowadzeniu danych w arkuszu danych wykres jest automatycznie aktualizowany w celu ich odzwierciedlenia. W arkuszu danych każdy wiersz lub każda kolumna serii są wyróżniane za pomocą innego koloru; każdy kolor odpowiada kolorowi skojarzonego znacznika danych na wykresie, co ułatwia odróżnianie serii.

Składnik Arkusz kalkulacyjny

Składnik Arkusz kalkulacyjny to składnik Microsoft Office Web Component, którego można użyć do wyświetlania obliczeń w arkuszu kalkulacyjnym na stronie sieci Web. Użytkownicy mogą używać arkusza kalkulacyjnego i zmieniać zawarte w nim dane za pomocą przeglądarki sieci Web. Po zmianie danych w arkuszu kalkulacyjnym aktualizowany jest korzystający z nich wykres. Arkusz kalkulacyjny i wykres muszą się znajdować na tej samej stronie sieci Web.

Można utworzyć arkusz kalkulacyjny w dowolnym programie do projektowania obsługującym składniki Microsoft Office Web Components, takim jak program Microsoft Access albo Microsoft FrontPage. Jeżeli dane znajdują się już w arkuszu programu Microsoft Excel, to można je opublikować w postaci interakcyjnego arkusza. Można również utworzyć wykres korzystający z danych zawartych w arkuszu programu Excel. Po opublikowaniu wykresu w postaci wykresu interakcyjnego opublikowany zostanie również interakcyjny arkusz kalkulacyjny. Aby uzyskać więcej informacji o publikowaniu formantów arkuszy kalkulacyjnych, zobacz Pomoc programu do projektowania.

Składnik Tabela przestawna

Składnik Tabela przestawna to składnik Office Web Component, którego można użyć do prezentacji na stronie sieci Web danych z bazy danych lub z innego źródła. Użytkownicy mogą interakcyjnie pracować z listą tabeli przestawnej za pomocą przeglądarek sieci Web.

Wykres utworzony na podstawie listy tabeli przestawnej można filtrować i sortować, a jego układ ponownie rozmieszczać, tak jak w przypadku listy tabeli przestawnej. Po zmianie danych na liście tabeli przestawnej wykres jest automatycznie aktualizowany, a w przypadku wykonania jakiejkolwiek operacji na danych stanowiących podstawę wykresu lista tabeli przestawnej jest automatycznie aktualizowana w celu uzyskania zgodności. Na przykład po usunięciu pola z wykresu to samo pole zostanie usunięte z listy tabeli przestawnej. Lista tabeli przestawnej i wykres muszą znajdować się na tej samej stronie sieci Web.

Przed przystąpieniem do tworzenia wykresu na podstawie listy tabeli przestawnej należy utworzyć, zaprojektować i uzyskać dostęp do niezbędnych danych listy tabeli przestawnej. Listę tabeli przestawnej można utworzyć w programie do projektowania obsługującym składniki Microsoft Office Web Component, takim jak widok Projekt strony dostępu do danych w programie Microsoft Access, lub opublikować za pomocą programu Microsoft Excel. Aby uzyskać więcej informacji o tworzeniu listy tabeli przestawnej, zobacz Pomoc programu do projektowania.

Tabela lub kwerenda w bazie danych

Można utworzyć wykres na podstawie danych pochodzących z tabeli, kwerendy lub widoku dostępnych z programu do projektowania. Na przykład można wykorzystać dane z tabeli lub kwerendy bazy danych programu Microsoft Access lub projektu programu Microsoft Access połączonego z bazą danych programu Microsoft SQL Server. Po zaktualizowaniu danych i odświeżeniu strony, na której znajduje się wykres, aktualizowany jest wykres. Można również dodawać, usuwać, sortować i filtrować pola na wykresie w celu organizowania danych w różny sposób.

W zależności od typu bazy danych, do której trzeba uzyskać dostęp i używanego programu do projektowania, może być konieczne skonfigurowanie źródła danych lub innych metod dostępu do danych, a następnie skonfigurowanie uprawnień dostępu. Źródło danych to przechowywane fragmenty informacji, czasami w postaci pliku tekstowego, zawierające nazwę sterownika bazy danych i inne istotne informacje używane do ustanawiania połączenia i pobierania danych. Aby uzyskać informacje o sposobie uzyskiwania dostępu do danych z bazy danych, zobacz Pomoc programu do projektowania.

Formant źródła danych

Formant źródła danych to formant używany w niektórych programach do nawiązywania połączenia z danymi. Na przykład po umieszczeniu formularza bazy danych na stronie dostępu do danych programu Microsoft Access formant źródła danych jest używany do łączenia danych z bazy danych ze stroną sieci Web. Po utworzeniu wykresu na podstawie takiego formantu informacje o połączeniu są ustanowione. Aby uzyskać więcej informacji dotyczących używania formantu źródła danych, zobacz Pomoc programu do projektowania.


Praca z arkuszem danych

Jeżeli wykres utworzono, wpisując dane do arkusza danych, to można użyć poniższych procedur do pracy z arkuszami danych.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  3. W obszarze Polecenia ogólne, na liście Zaznacz kliknij pozycję Obszar roboczy wykresu.
  4. Kliknij kartę Arkusz danych.
  5. Wykonaj co najmniej jedną z następujących czynności:

    Wprowadzanie danych

    Uwaga Można wprowadzić etykiety kategorii lub serii w pierwszej kolumnie lub pierwszym wierszu arkusza danych.

    1. Zaznacz komórkę w arkuszu danych.
    2. Wpisz dane, które chcesz wprowadzić do komórki.
    3. Naciśnij klawisz ENTER, aby wprowadzić dane i przenieś w dół zaznaczenie komórki albo naciśnij klawisz TAB, aby wprowadzić dane i przenieść zaznaczenie komórki w prawą stronę.

    Czyszczenie arkusza danych

    • Kliknij przycisk Wyczyść arkusz danych [image].
    Wszystkie dane znajdujące się w arkuszu danych i na wykresie zostaną wyczyszczone. Tej czynności nie można cofnąć.

    Zmienianie wierszy kategorii na wiersze serii lub wierszy serii na wiersze kategorii

    • Kliknij przycisk Według wierszy — Według kolumn [image].

    Kopiowanie i wklejanie danych

    1. Zaznacz dane, które chcesz skopiować w arkuszu danych lub w innym programie.
    2. Kliknij przycisk Kopiuj [image].
    3. Kliknij lewą górną komórkę obszaru, w którym chcesz wkleić dane.
    4. Kliknij przycisk Wklej [image].

    Uwaga Wklejone dane zastąpią dotychczasową zawartość komórek.


Zmienianie danych źródłowych wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij wykres prawym przyciskiem myszy i kliknij polecenie Dane w menu skrótów.
  3. Na karcie Źródło danych zaznacz nowe źródło danych, a następnie ustaw dotyczące go opcje.


Tworzenie wykresu złożonego

Wykres złożony używa dwóch lub większej liczby typów wykresów, aby podkreślić, że zawiera różne rodzaje informacji. Na wykresie w następnym przykładzie pokazano jedną serię danych (Rzeczywiste) w postaci wykresu kolumnowego, a drugą (Prognozowane) w postaci wykresu liniowego.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Określ, która seria ma być przedstawiona za pomocą innego typu wykresu.

  3. Wykonaj jedną z następujących czynności:

    Zmienianie typu wykresu w przypadku serii

    1. Kliknij serię, której typ wykresu chcesz zmienić.

    2. Na pasku narzędzi kliknij przycisk Typ wykresu [image].
    3. Kliknij żądany typ wykresu na liście, a następnie kliknij żądany podtyp.

    Zmienianie typu wykresu w przypadku grupy serii i dodawanie osi

    1. Na pasku narzędzi wykresu kliknij przycisk Polecenia i opcje, a następnie kliknij kartę Ogólne [image].

    2. W obszarze Polecenia ogólne, na liście Zaznacz kliknij pozycję Obszar roboczy wykresu.

    3. Kliknij kartę Grupy serii.

    4. W obszarze Grupy serii, w polu Wybierz jedną lub więcej serii zaznacz serie, których typ wykresu chcesz zmienić.

    5. Na liście Operacja kliknij pozycję Nowa grupa.

    6. Aby wyświetlić oś pomocniczą w celu odzwierciedlenia odmiennej skali grupy serii, kliknij grupę w polu Grupy w obszarze Dodawanie osi, a następnie wybierz pozycję drugiej osi w polu Położenie osi. Na przykład, jeśli oś podstawowa znajduje się po lewej stronie wykresu, a druga oś ma być po prawej stronie wykresu, to kliknij pozycję Z prawej w polu Położenie osi, a następnie kliknij przycisk Dodaj.

    7. Zaznacz zgrupowaną serię na wykresie, aby zmienić typ jej wykresu na inny.

    8. Kliknij kartę Typ.

    9. Kliknij na liście żądany typ wykresu, a następnie kliknij podtyp w polu po lewej stronie.

Uwaga Nie wszystkie typy wykresów można łączyć. Na przykład nie można łączyć wykresów typu 2-W i 3-W, wykresu słupkowego i kolumnowego oraz wykresu kolumnowego i kołowego.


Tworzenie wielu wykresów w obszarze roboczym wykresu

Po utworzeniu wykresu na podstawie danych pochodzących z listy tabeli przestawnej, tabeli lub kwerendy bazy danych można utworzyć wiele wykresów w tym samym obszarze roboczym wykresu, aby uprościć porównywanie różnych cech danych. Poniższy przykład przedstawia wiele wykresów umożliwiających porównanie danych o sprzedaży za pomocą osobnego wykresu każdego sprzedawcy. Wykresy w przedstawionym przykładzie mają również tę samą skalę, ale jest to opcjonalne.

Wiele wykresów w jednym obszarze roboczym wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje, a następnie kliknij kartę Ogólne [image].
  3. W obszarze Polecenia ogólne, na liście Zaznacz wybierz pozycję Obszar roboczy wykresu.
  4. W obszarze Dodaj kliknij przycisk Kreśl wiele wykresów przycisk Kreśl wiele wykresów.
  5. Aby użyć tej samej skali osi dla wszystkich wykresów, kliknij przycisk Ta sama skala dla wielu wykresów [image].
  6. Na pasku narzędzi kliknij przycisk Lista pól [image], a następnie użyj pasków przewijania i wskaźników rozwijania (pola Pole plus oraz Pole minus), aby znaleźć pole, które chcesz dodać do wykresu.
  7. Kliknij pole i przeciągnij je do obszaru upuszczania na wykresie, na którym widnieje napis Upuść pola wielu wykresów tutaj.

    Można dodać wiele pól do obszaru wielu wykresów.


Zmienianie sposobu wyświetlania wielu wykresów

Jeśli w obszarze roboczym wykresu znajduje się wiele wykresów, to można określić, czy mają być one wyświetlane w poziomie lub pionie oraz zmienić liczbę wykresów wyświetlanych w każdym wierszu lub kolumnie.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje, a następnie kliknij kartę Ogólne.
  3. W polu Zaznacz kliknij pozycję Obszar roboczy wykresu.
  4. W obszarze Obszar roboczy wykresu, na liście Układ wykresu kliknij pozycję W poziomie lub W pionie.

    Po wybraniu pozycji Automatycznie wykresy będą wyświetlane w pionie lub w poziomie w zależności od rozmiaru i kształtu obszaru roboczego.

  5. Aby ograniczyć liczbę wykresów wzdłuż i wszerz obszaru roboczego wykresu, wpisz maksymalną liczbę wykresów, które mogą być wyświetlane, w polu Maksymalnie na wykres wierszy/kolumn.

    Uwaga Ta opcja jest dostępna tylko po kliknięciu pozycji W poziomie lub W pionie na liście Układ wykresu.


Korzystanie z wykresu w przeglądarce — informacje

Praca w przeglądarce w porównaniu z pracą w programie do projektowania

Składnik Microsoft Office Chart Component umożliwia utworzenie w programie do projektowania wykresu, który będzie dostępny w czasie uruchomienia w przeglądarce sieci Web lub innym środowisku wykonawczym. Programy Microsoft Excel, Microsoft FrontPage i Microsoft Access to programy do projektowania, których można użyć do tworzenia i modyfikowania wykresów.

Funkcje czasu uruchomienia omówione w tym temacie są dostępne dla użytkowników, którzy zainstalowali składniki Microsoft Office Web Components. Składniki te można zainstalować, instalując pakiet Microsoft Office XP lub, jeżeli firma ma licencję pakietu Office XP w trybie dostępu na lokalizację, pobierając składniki Office Web Components z firmowego intranetu. Użytkownicy powinni również mieć przeglądarkę sieci Web z pełną obsługą interakcyjnych wykresów, taką jak Internet Explorer w wersji 5 lub nowszej. Jeżeli projektant planuje utworzenie wykresów do użytku w programie innym niż przeglądarka sieci Web, na przykład w formularzu programu Microsoft Visual Basic do przeglądania jako część niestandardowego rozwiązania, to powinien zapoznać się z Pomocą programu do projektowania, aby dowiedzieć się, w jaki sposób użytkownicy mogą uzyskać dostęp do wykresu i interaktywnie z nim pracować.

Co użytkownicy mogą zrobić w przeglądarce

W przeglądarce, w czasie uruchomienia, użytkownicy, których systemy spełniają konieczne wymagania, mogą wyświetlać utworzony wykres. Mogą zobaczyć, jak wykres jest automatycznie aktualizowany, aby odzwierciedlić zmiany danych, a także interaktywnie pracować z wykresem na dozwolonym poziomie. Jeżeli na przykład utworzysz wykres używający cen giełdowych i dane będą aktualizowane na podstawie najnowszych cen, to użytkownicy zobaczą zmianę wykresu odzwierciedlającą nową cenę. Jeśli zezwolisz na wyświetlanie paska narzędzi, użytkownicy będą mogli także zmienić typ wykresu, zmienić niektóre elementy formatowania i — zależnie od typu danych — pokazać, ukryć lub zreorganizować dane na wykresie.

Zmienianie danych odzwierciedlonych na wykresie Użytkownicy mogą zmieniać dane odzwierciedlane na wykresie w zależności od typu danych źródłowych i udzielonego im poziomu dostępu. Na przykład, możesz dostarczyć arkusz kalkulacyjny i odpowiadający mu wykres na stronie sieci Web i umożliwić użytkownikom wprowadzanie zmian w niektórych, ale nie we wszystkich danych w arkuszu kalkulacyjnym. Gdy użytkownik zmieni dane w arkuszu, wykres zostanie zaktualizowany. Lub, jeśli wykres jest oparty na liście tabeli przestawnej lub tabeli bądź kwerendzie bazy danych i wyświetlasz pola na wykresie, użytkownicy mogą przenosić, rozmieszczać ponownie, filtrować i sortować pola bezpośrednio na wykresie.

Zmienianie wykresu Można umożliwić użytkownikom dostęp do paska narzędzi wykresu w oknie dialogowym Polecenia i opcje, zezwalając im na dokonanie wielu zmian, których można także dokonywać w programie do projektowania. Na przykład użytkownicy mogą zmieniać typ wykresu lub dowolny typ formatowania na wykresie. W przeciwnym przypadku można wyłączyć używanie okna dialogowego Polecenia i opcje lub paska narzędzi i w zamian napisać skrypty umożliwiające jedynie wybrane zmiany. Dowiedz się więcej o uzyskiwaniu pomocy w programowaniu wykresu.

W jaki sposób wersja przeglądarki wpływa na operacje, które mogą wykonać użytkownicy Interaktywna praca z wykresem znaczy, że można zmienić dane źródłowe wykresu i obserwować aktualizację wykresu. Aby móc interaktywnie pracować z wykresem, użytkownicy muszą mieć program Microsoft Internet Explorer w wersji 4.01 lub nowszej. Zaleca się, aby użytkownicy zainstalowali program Internet Explorer 5 lub w wersji nowszej, dostarczany wraz z pakietem Microsoft Office XP, aby w pełni wykorzystać interaktywne funkcje wykresu i jego danych źródłowych.

Pomoc dla użytkownika przeglądarki Użytkownicy przeglądarek mają dostęp do wersji czasu uruchomienia Pomocy wykresu, która zawiera tematy dotyczące funkcji domyślnych czasu uruchomienia, takich jak zmiana typu wykresu, ukrywanie lub pokazywanie legendy, sortowanie, filtrowanie i przenoszenie pól. Wersja czasu uruchomienia Pomocy nie zawiera informacji dotyczących używania okna dialogowego Polecenia i opcje. W przypadku modyfikowania funkcji dozwolonych w czasie uruchomienia trzeba zapewnić pomoc lub instrukcje na stronie sieci Web.

Użytkownicy mają w przeglądarce także dostęp do tematów Pomocy systemu i wszelkiej zawartości Pomocy dołączanej do źródła danych wykresu. Na przykład, jeżeli wykres korzysta z danych z listy tabeli przestawnej, to użytkownicy mogą skorzystać z Pomocy składnika PivotTable Component, aby dowiedzieć się, jak zmienić dane na liście tabeli przestawnej.


Ograniczanie używania wykresu w przeglądarce — informacje

Niektóre funkcje wykresu są dostępne tylko podczas pracy w programie do projektowania. Pozostałe funkcje są dostępne zarówno podczas projektowania wykresu, jak i używania go w przeglądarce. Projektant może jednak ograniczyć dostępność tych funkcji w przeglądarce, zmieniając ustawienia właściwości.

Możliwość korzystania z funkcji udostępnionych użytkownikom za pomocą przeglądarki zależy jednak przede wszystkim od używanej przez nich przeglądarki i posiadania odpowiedniej licencji. Aby w pełni korzystać z możliwości wykresu, użytkownicy potrzebują programu Microsoft Internet Explorer w wersji 4.01 lub nowszej oraz licencji Office XP. Za pomocą programu Microsoft Internet Explorer 4.0 licencjonowani użytkownicy mogą uzyskać dostęp do niektórych funkcji wykresu. W innych przeglądarkach użytkownicy nie mogą przeglądać wykresów ani interakcyjnie z nimi pracować. Użytkownicy, którzy nie posiadają licencji Office XP lecz używają programu Microsoft Internet Explorer w wersji 4.01 lub nowszej, mogą przeglądać wykres, ale nie mogą interakcyjnie z nim pracować.

Funkcje niedostępne w przeglądarce

W przeglądarce użytkownicy nie mogą zmieniać informacji dotyczących źródłowej bazy danych, pól bazy danych ani danych źródłowych, jeśli wykres utworzono na podstawie bazy danych lub listy tabeli przestawnej. Tylko projektant wykresu może określić używaną źródłową bazę danych i podzbiór danych udostępniony w postaci danych źródłowych na wykresie.

W przeglądarce użytkownicy mogą wyświetlić jedynie udostępnione dane; jeśli dostęp do bazy danych wymaga podania hasła, użytkownicy muszą wprowadzić hasło, aby wyświetlić dane. Użytkownicy mogą odświeżać wykres w przeglądarce, aby odzwierciedlić wszystkie zmiany wprowadzone w danych źródłowych, ale nie mogą uzyskać dostępu do źródłowej bazy danych ani zmieniać przechowywanych w niej danych.

Funkcje zazwyczaj dostępne w przeglądarce

Jeśli dana przeglądarka w pełni obsługuje wykresy, to użytkownicy mogą zmieniać wykres w przeglądarce podobnie jak w programie do projektowania, pod warunkiem, że udostępniono im taką możliwość. Na przykład można zezwolić na wyświetlanie paska narzędzi wykresu lub okna dialogowego Polecenia i opcje albo uniemożliwić ich wyświetlenie.

Podczas projektowania wykresu można wprowadzać ograniczenia dotyczące dodawania lub przenoszenia przez użytkowników pól z listy pól; sortowania, filtrowania i grupowania danych na wykresie utworzonym na podstawie bazy danych lub listy tabeli przestawnej; zmieniania danych w przypadku wykresu opartego na arkuszu kalkulacyjnym lub arkuszu danych; zmiany formatowania, typu wykresu itd. — wszystkie, które umożliwia program do projektowania.

Ograniczenia, które można ustawić

Aby zapobiec zmienianiu wykresu przez użytkowników lub ograniczyć dostęp do odpowiedniej części danych źródłowych, można uniemożliwić:

  • Dostęp do okna dialogowego Polecenia i opcje
  • Grupowanie elementów
  • Filtrowanie danych
  • Używanie znaczników zaznaczenia
Dodatkowe ograniczenia można wprowadzić za pomocą skryptów; aby uzyskać więcej informacji, zapoznaj się ze sposobem uzyskiwania Pomocy dla programistów wykresów.


Ograniczanie używania wykresu w przeglądarce

Po zmianie ustawienia w celu uniemożliwienia użytkownikowi wykonania określonego zadania na wykresie nie będzie można wykonać tego zadania w programie do projektowania do momentu ponownej zmiany ustawienia.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Zaznacz obszar roboczy wykresu, klikając pusty obszar na zewnątrz obszaru kreślenia, ale w obrębie granic wykresu.

  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Pokaż/Ukryj.

  4. W obszarze Użytkownicy mogą widzieć wykonaj jedną z następujących czynności:

    Uniemożliwianie dodawania, zmieniania lub usuwania filtrów

    • Wyczyść pole wyboru Zezwalaj na filtrowanie przestawne.

    Uniemożliwianie grupowania lub zmieniania układu

    • Wyczyść pole wyboru Zezwalaj na grupowanie przestawne.

    Uniemożliwianie wyświetlania wskaźników zaznaczenia

    • Wyczyść pole wyboru Znaczniki zaznaczenia.

    Uniemożliwianie dostępu do okna dialogowego Polecenia i opcje

    • Wyczyść pole wyboru Okno dialogowe Polecenia i opcje.


Drukowanie wykresu

Aby wydrukować wykres, trzeba wydrukować całą stronę sieci Web.

  • Chcąc wydrukować wykres z okna projektowania, zobacz Pomoc programu do projektowania, aby uzyskać szczegółowe instrukcje dotyczące drukowania strony sieci Web.

  • Aby wydrukować wykres z przeglądarki, kliknij polecenie Drukuj w menu Plik programu Microsoft Internet Explorer.

Uwaga Jeśli wykres jest szerszy lub dłuższy niż drukowana strona, to obszary nie mieszczące się na stronie nie zostaną wydrukowane.


Pokazywanie lub ukrywanie alertów pasywnych

Alert pasywny wskazuje, że dany wykres zawiera błąd. Alert pojawia się w postaci wykrzyknika w dolnym lewym rogu wykresu i po kliknięciu wyświetla informacje na temat alertu. Alerty pasywne pojawiają się w przypadku wystąpienia błędu, na przykład, jeśli nie można znaleźć pliku tekstury lub połączyć się z bazą danych.

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  2. W obszarze Polecenia ogólne, w polu Zaznacz kliknij pozycję Obszar roboczy wykresu.
  3. Kliknij kartę Pokaż/Ukryj.
  4. W obszarze Błędy zaznacz lub wyczyść pole wyboru Pokaż alerty pasywne.


Pokazywanie lub ukrywanie etykietek ekranowych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  3. W obszarze Polecenia ogólne, w polu Zaznacz kliknij pozycję Obszar roboczy wykresu.
  4. Kliknij kartę Pokaż/Ukryj.
  5. W obszarze Pokaż domyślnie zaznacz lub wyczyść pole wyboru Etykietki ekranowe.


Dodawanie i usuwanie pól — informacje

Podczas tworzenia wykresu na podstawie danych pochodzących z bazy danych lub z listy tabeli przestawnej w danych źródłowych należy wybrać pola, które będą wyświetlane na wykresie.

Przeglądanie pól dostępnych dla wykresu

Aby obejrzeć listę pól dostępnych w danych źródłowych oraz dodawać pola do obszarów kategorii, serii, filtrów i danych wykresu, należy korzystać z listy pól wykresu. Na liście pól zestaw pól zawiera jedno lub kilka pól. Pola lub zestawy pól, których nazwy nie są wyświetlane pogrubioną czcionką, mogą być wyświetlane na wykresie. Zestawy pól, których nazwy są wyświetlane pogrubioną czcionką, zawierają jedno lub kilka pól, które już są wyświetlone. Aby pokazywać lub ukrywać dodatkowe pola w każdym zestawie pól, można przewijać i klikać wskaźniki rozwijania (pola Pole plus lub Pole minus ). Pola pochodzące z tego samego zestawu pól muszą być wyświetlane w tym samym obszarze upuszczania.

W przypadku wykresu utworzonego na podstawie danych źródłowych pochodzących z bazy danych OLAP, na przykład utworzonej za pomocą programu Microsoft SQL Server OLAP Services, można zauważyć, że niektóre pola mogą być przenoszone tylko do obszarów serii lub kategorii. Inne pola, wymienione w obszarze Sumy, mogą być używane tylko jako pola danych.

Dodawanie pól do obszaru kategorii lub serii

Pola kategorii i serii służą do podsumowywania i porównywania danych. Unikatowe elementy danych w polu wyświetlane są w nich jako serie (powiązane punkty danych) albo jako kategorie (powiązane grupy, które się składają z jednego punktu dla każdej serii).

Pola kategorii i serii na wykresie

1 Pole serii, pokazane z legendą. Nazwy w legendzie to elementy zawarte w polu.

2 Pole kategorii. Nazwy pokazane pod osią x to elementy zawarte w polu kategorii.

Dodawanie pól do obszaru danych

Pola danych zawierają wartości do podsumowywania na wykresie. Po dodaniu pola do obszaru danych wartości pola są wyświetlane jako znaczniki danych dla elementów kategorii i serii.

Pole danych na wykresie

1 Pole danych

2 Znaczniki danych reprezentujące punkty danych

Dodawanie pól do obszaru filtru

Pole filtru jest podobne do pola strony w raporcie tabeli przestawnej programu Microsoft Excel. Pól filtrów można używać do ograniczania widoku do określonej części dostępnych danych. Po wybraniu elementu w polu filtru dane będą wyświetlane i obliczane wyłącznie dla tego elementu. Na przykład po dodaniu pola filtru Rok na wykresie mogą być wyświetlane dane dotyczące wszystkich lat albo tylko jednego roku naraz.

Wykres z polem filtru

1 Pole filtru

2 Aktualnie wyświetlany element pola filtru

3 Znaczniki danych dla wybranego roku

Dodawanie pól sum

Dodając do wykresu pola sum, można tworzyć nowe pola danych. Pola sum zapewniają podsumowane dane do użycia jako pola danych. Na przykład jeżeli w danych źródłowych znajduje się pole Sprzedaż, w którym wyświetlana jest wartość danej sprzedaży, to można dodać pole sumy Suma sprzedaży, w którym będzie obliczana całkowita wartość sprzedaży lub zamienić pole sumy na pole Liczba sprzedanych, aby obliczyć, ile sztuk zostało sprzedanych.

Usuwanie pól

Aby wyeliminować dane, których nie trzeba oglądać ani podsumowywać, można usunąć pola z wykresu. Usunięte pole przestaje być wyświetlane na wykresie, ale można je nadal przeglądać na liście pól.

Przenoszenie pól

Po dodaniu pola do wykresu można je przenosić do innych obszarów. Przesunięcie pola zmienia układ wykresu i sposób wyświetlania danych.

Wpływ dodawania i usuwania pól na filtrowanie

Po usunięciu pola i jego ponownym dodaniu ustawienia filtru są zachowywane.


Dodawanie, zmienianie lub usuwanie pola

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

Dodawanie pola

  1. Na pasku narzędzi wykresu kliknij przycisk Lista pól [image].

  2. Użyj pasków przewijania i wskaźników rozwijania (pola Pole plus i Pole minus), aby znaleźć pole, które chcesz dodać do wykresu.

  3. Kliknij pole i przeciągnij je do odpowiedniego obszaru upuszczania na wykresie.

    Można dodać wiele pól do każdej z lokalizacji.

    Uwagi

    • Zamiast przeciągać pole można na liście pól zaznaczyć obszar, do którego należy dodać pole (lista obszarów znajduje się w dolnej części listy pól), a następnie kliknąć przycisk Dodaj do. Jeśli po zaznaczeniu odpowiedniego obszaru przycisk Dodaj do jest niedostępny, to wybrane pole może być niedostępne do użycia jako pole kategorii, serii, danych lub filtru.

    • Jeżeli wykres utworzono na podstawie danych źródłowych pochodzących z bazy danych OLAP, to jako pola kategorii, serii lub filtrów mogą być użyte wyłącznie pola, które nie są wymienione w obszarze Sumy na liście pól.

    • Do obszaru na wykresie można dodać kilka pól. Sposób umieszczenia pól na wykresie określa hierarchiczną kolejność wyświetlania danych. Pola zewnętrzne mogą być rozwijane lub zwijane, aby pokazać więcej lub mniej informacji w polach wewnętrznych.

    • Obszar multiwykresu jest dostępny tylko wówczas, jeżeli wykres utworzono na podstawie danych pochodzących z listy tabeli przestawnej albo tabeli lub kwerendy bazy danych, a użytkownik zaznaczył opcję Wiele wykresów opcja Wiele wykresów na karcie Ogólne w oknie dialogowym Polecenia i opcje.

Zmienianie funkcji podsumowania w przypadku pola danych

  1. Kliknij pole danych zawierające wartości, które chcesz podsumować.

  2. Na pasku narzędzi wykresu kliknij przycisk Autoobliczanie [image], a następnie kliknij żądaną funkcję podsumowania.

Uwaga Przycisk Autoobliczanie jest niedostępny, jeśli dane źródłowe wykresu nie zezwalają na dodawanie pól sum — na przykład dane źródłowe pochodzą z bazy danych OLAP.

Usuwanie pola

Po usunięciu pola z wykresu dane z tego pola nie są już wyświetlane, pole jest jednak nadal dostępne do przeglądania na liście pól.

  1. Kliknij etykietę pola, które chcesz usunąć z wykresu.

  2. Przeciągnij pole poza wykres tak, aby wskaźnik zmienił kształt na Wskaźnik z czerwonym X.


Przenoszenie pola na wykresie

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Jeśli obszary upuszczania wykresu nie są wyświetlane, pokaż je, klikając wykres prawym przyciskiem myszy, a następnie klikając polecenie Obszary upuszczania w menu skrótów.
  3. Na wykresie kliknij pole, które chcesz przenieść, a następnie przeciągnij je do momentu aż wskaźnik zmieni kształt na reprezentujący odpowiedni obszar.
    Taki wskaźnik | Reprezentuje taki obszar
    Wskaźnik obszaru serii | Obszar serii
    Wskaźnik obszaru kategorii | Obszar kategorii
    Wskaźnik obszaru filtru | Obszar filtru
    Wskaźnik obszaru danych | Obszar danych
    Wskaźnik obszaru multiwykresu | Obszar multiwykresu
  4. Zwolnij przycisk myszy.

Uwaga Przedstawione kształty wskaźników mają zastosowanie tylko podczas przenoszenia pól w obrębie wykresu, a nie obowiązują podczas dodawania pól z listy pól.


Zmienianie układu pól na wykresie — informacje

Po utworzeniu wykresu na podstawie danych pochodzących z bazy danych lub listy tabeli przestawnej można kontrolować sposób pokazywania danych za pomocą przenoszenia pól i dostosowywania układu. Inny układ zezwala na porównywanie wartości różnych elementów danych w sposób zrozumiały dla danego audytorium. Po udostępnieniu wykresu użytkownicy przeglądarki mogą wprowadzać dalsze zmiany w jego początkowym układzie.

Używanie obszarów upuszczania

Można zmieniać układ wykresu, przenosząc pola do wstępnie zdefiniowanych obszarów upuszczania w obszarze roboczym wykresu. Aby to wykonać, obszary upuszczania muszą być widoczne na wykresie.

Obszary upuszczania są wyświetlane na różne sposoby, w zależności od typu wykresu. Na przykład obszar upuszczania serii nie jest wyświetlany w przypadku wykresów kołowych, ponieważ składają się one tylko z jednej serii. Podczas kreślenia wielu wykresów widoczny będzie obszar upuszczania dla pól wielu wykresów. Ten typ obszaru upuszczania nie jest wyświetlany w przypadku pojedynczych wykresów.

Po przeniesieniu pól do obszarów upuszczania, co powoduje zasłonięcie podpisów obszarów upuszczania, można nadal przeciągać do nich dodatkowe pola.

Przenoszenie pól do obszarów kategorii i serii

Po przeniesieniu pola do obszaru serii unikatowe elementy danych w polu są wyświetlane jako serie danych na wykresie. Serie są reprezentowane przez kolorowe znaczniki danych, a ich nazwy pojawiają się w legendzie wykresu.

Po przeniesieniu pola do obszaru kategorii unikatowe elementy danych są wyświetlane jako kategorie, czyli powiązane grupy danych. Każda kategoria składa się z jednego punktu z każdej z serii danych. Etykiety kategorii zazwyczaj pojawiają się w poprzek osi x wykresu, jednak zależy to od użytego typu wykresu.

Przenoszenie pól do obszaru danych

Pola danych zawierają wartości do podsumowania na wykresie. Po przeniesieniu pola do obszaru danych zawarte w nim wartości służą jako dane mierzone na wykresie.

Przenoszenie pól do obszaru filtru

Pole filtru jest podobne do pola strony w raporcie tabeli przestawnej programu Microsoft Excel. Pola filtru zezwalają na ograniczenie widoku do określonej części dostępnych danych. Na przykład po przeniesieniu pola Produkt do obszaru filtru można wyświetlić na wykresie kategorie i serie wartości dla jednego produktu naraz.

Przenoszenie pól do obszaru multiwykresu

Po utworzeniu wykresu na podstawie danych z listy tabeli przestawnej, tabeli lub kwerendy bazy danych można wykreślić wiele wykresów. Po przeniesieniu pola do obszaru multiwykresu elementy danego pola stają się oddzielnymi wykresami. Na przykład po przeniesieniu pola Sprzedawca do obszaru multiwykresu wykres zostanie utworzony na podstawie danych każdego sprzedawcy zawartych w tym polu. W następującym przykładzie pole Sprzedawca znajduje się w obszarze multiwykresu, lecz jest filtrowane, dlatego wyświetla pojedyncze wykresy dotyczące sprzedawców Buchanan i Davolio.

Filtrowane pole Sprzedawca w obszarze multiwykresu

Przenoszenie pól kategorii lub serii na poziomy wewnętrzne lub zewnętrzne

Jeśli wykres zawiera kilka pól serii lub kategorii, to pola położone najbliżej danych są nazywane polami wewnętrznymi. Pozostałe pola to pola zewnętrzne. W poniższym przykładzie pole Rok jest polem zewnętrznym, a pole Sprzedawca jest polem wewnętrznym. Elementy pola wewnętrznego są wyświetlane jako nazwiska sprzedawców, a elementy pola zewnętrznego są wyświetlane jako lata 1997 i 1998.

Wiele pól na wykresie

1 Elementy pola wewnętrznego

2 Elementy pola zewnętrznego

Można rozwijać i zwijać pola, aby pokazywać więcej lub mniej informacji w konkretnym polu. W powyższym przykładzie można zwinąć pole zewnętrzne (Rok), aby nie wyświetlać elementów pola wewnętrznego.

Wykres ze zwiniętym polem

Dodawanie i usuwanie pól

Układ wykresu nie musi zawierać wszystkich pól dostępnych w danych źródłowych. Jeśli dostępnych jest więcej danych, to można dodać pola do wykresu. Na przykład, jeśli na wykresie podsumowano dochód ze sprzedaży, a dane źródłowe zawierają także wielkość sprzedaży, to można dodać pole Ilość jako pole danych, aby podsumować zarówno dochód ze sprzedaży, jak i ilość sprzedanego produktu. Z układu wykresu można także usunąć pola, które mają być niewidoczne.

Ograniczenia w dodawaniu i przenoszeniu pól

Podczas pracy z wykresem utworzonym na podstawie danych źródłowych pochodzących z bazy danych OLAP, na przykład utworzonej za pomocą programu Microsoft SQL Server OLAP Services, można zauważyć, że niektóre pola można przenosić tylko do obszarów serii, kategorii i filtru oraz że pola w obszarze danych nie mogą być przenoszone do innych obszarów.

Wpływ zmiany układu na filtrowanie

Po przeniesieniu lub usunięciu pola ustawienia filtru są zachowywane. Oznacza to, że po ponownym przeniesieniu pola serii lub kategorii do obszaru filtru i z powrotem elementy poprzednio ukryte będą ponownie ukryte. Jeśli pole zostanie usunięte, a następnie dodane ponownie do układu, to te same elementy będą znowu ukryte.

Ograniczanie używania wykresu w przeglądarce

Można ograniczyć możliwość zmieniania układu wykresu przez użytkowników, uniemożliwiając dodawanie i przenoszenie pól w czasie uruchomienia.


Zaznaczanie elementu wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać szczegółowe informacje, zobacz Pomoc programu do projektowania.

    Uwaga Aby uaktywnić wykres, należy kliknąć go raz albo dwa razy, w zależności od programu do projektowania. Na przykład na stronie dostępu do danych wystarczy kliknąć raz, aby zaznaczyć wykres (na jego obramowaniu pojawią się białe uchwyty zaznaczenia). Drugie kliknięcie powoduje uaktywnienie wykresu (wokół wykresu pojawi się przerywane obramowanie).

  2. Wykonaj jedną z następujących czynności:

    Zaznaczanie elementu za pomocą myszy

    • Kliknij raz, aby zaznaczyć grupę elementów, na przykład grupę znaczników danych w serii danych.
    • Chcąc zaznaczyć określony element w obrębie grupy, taki jak poszczególny znacznik danych w serii danych, kliknij raz, aby zaznaczyć grupę, a następnie kliknij określony element, który chcesz zaznaczyć.

    Zaznaczanie elementu za pomocą okna dialogowego Polecenia i opcje

    1. Kliknij wykres prawym przyciskiem myszy, a następnie kliknij polecenie Polecenia i opcje.
    2. Kliknij kartę Ogólne.
    3. W polu Zaznacz kliknij żądany element wykresu. Na przykład aby zaznaczyć pierwszą oś wartości na wykresie, kliknij na liście pozycję Oś wartości 1.


Zmienianie typu wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Wykonaj jedną z następujących czynności:

    • Aby zmienić typ wykresu dla całego wykresu, zaznacz obszar roboczy wykresu, klikając pusty obszar poza obszarem kreślenia, ale w granicach wykresu.

    • Aby zmienić typ wykresu dla pojedynczej serii danych, zaznacz serię danych.

      Uwaga Zmiana typu wykresu dla pojedynczej serii powoduje utworzenie wykresu połączonego. Nie wszystkie typy wykresów można połączyć. Na przykład nie można połączyć wykresów typów 2-W i 3-W, wykresu kolumnowego i słupkowego oraz wykresu kolumnowego i kołowego.

  3. Na pasku narzędzi kliknij przycisk Typ wykresu [image].
  4. Na liście kliknij żądany typ wykresu, a następnie kliknij żądany podtyp.


Dodawanie, usuwanie lub zmienianie osi

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

    Dodawanie osi

    1. Kliknij obszar roboczy wykresu (pusty obszar pomiędzy obszarem kreślenie i granicą wykresu).
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Grupy serii.
    3. W obszarze Grupy serii, w polu Wybierz jedną lub więcej serii zaznacz grupę serii, dla której chcesz dodać oś.
    4. Aby oś odzwierciedlała różne serie, można je grupować, rozgrupowywać lub scalać z innymi grupami.
    5. W obszarze Dodawanie osi, w polu Grupy zaznacz grupę, dla której chcesz dodać oś, a następnie w polu Położenie osi wybierz miejsce wyświetlania osi.
    6. Kliknij przycisk Dodaj.

    Usuwanie osi

    1. Kliknij oś, którą chcesz usunąć.
    2. Naciśnij klawisz DELETE.

    Zmienianie położenia osi

    1. Kliknij oś, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
    3. W obszarze Położenie, w polu Położenie zaznacz żądaną opcję.

    Dodawanie, zmienianie lub usuwanie tytułu na osi

    1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
    2. Wykonaj co najmniej jedną z następujących czynności:

    Dodawanie tytułu

    1. Na wykresie kliknij element, do którego chcesz dodać tytuł: obszar roboczy lub oś wykresu.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.

    3. Kliknij przycisk Dodaj tytuł.

    Usuwanie tytułu

    1. Kliknij tytuł, który chcesz usunąć.

    2. Naciśnij klawisz DELETE.

    Zmienianie tytułu

    1. Kliknij tytuł, który chcesz zmienić.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image].

    3. Wykonaj co najmniej jedną z następujących czynności:

      Zmienianie formatu tekstu

      1. Kliknij kartę Format.

      2. Zaznacz żądane opcje w obszarze Format tekstu.

      Zmienianie położenia osi

      1. Kliknij kartę Format.

      2. W obszarze Położenie, w polu Położenie kliknij pozycję U góry, U dołu, Z lewej lub Z prawej.

      Zmienianie zawartości tytułu

      1. Kliknij kartę Format.

      2. W obszarze Podpis wpisz nowy tytuł w polu Podpis.

      Zmienianie koloru wypełnienia lub obramowania

      1. Kliknij kartę Obramowanie/Wypełnienie.

      2. Zaznacz żądane opcje w obszarze Obramowanie i obszarze Wypełnienie.

    Zmienianie czcionki lub rozmiaru tekstu wartości osi

    1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
    2. Kliknij tytuł osi, etykiety danych, etykiety wartości R-kwadrat i etykiety równania, tekst legendy, tytuł wykresu lub inne elementy tekstowe na wykresie, które chcesz zmienić.
    3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
    4. W obszarze Format tekstu zaznacz żądane opcje.

    Zmienianie odstępów znaczników osi i etykiet na osi kategorii

    Każda kategoria na osi kategorii jest identyfikowana przez etykietę i oddzielona od innych kategorii za pomocą znaczników osi. Można zmienić interwały, w jakich pojawiają się etykiety i znaczniki osi.

    1. Kliknij oś kategorii, którą chcesz zmienić.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skala.

    3. W obszarze Skala wykonaj co najmniej jedną z następujących czynności:
      • Wpisz liczbę w polu Odstępy między etykietami, aby określić częstotliwość oznaczania kategorii etykietami. Na przykład wpisz 1, aby każda kategoria otrzymała etykietę, wpisz 2, aby oznaczyć etykietą co drugą kategorię itd.
      • Wpisz liczbę w polu Odstępy między znacznikami osi, aby określić żądaną liczbę kategorii pomiędzy każdą parą znaczników osi. Na przykład wpisz 1, aby między każdą parą znaczników osi znajdowała się jedna kategoria, wpisz 2, aby między każdą parą znaczników osi znajdowały się dwie kategorie.

    Zmienianie miejsca przecięcia się osi kategorii z osią wartości

    1. Kliknij oś kategorii, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skala.

    3. W obszarze Osie przecinające się, na liście Przecięcie z kliknij oś, która ma się krzyżować z osią kategorii.

    4. Aby określić miejsce przecięcia się danej osi z osią kategorii, zaznacz pole wyboru Niestandardowe, a następnie wpisz wartość w polu obok.

    Zmienianie osi kategorii skali czasu

    Jeśli dane kategorii są danymi liczbowymi, wykres automatycznie używa osi skali czasu. Oś kategorii skali czasu wyświetla daty w kolejności chronologicznej, w określonych interwałach, nawet jeśli daty zawarte w danych są nieuporządkowane.

    1. Kliknij oś kategorii, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skala.
    3. W obszarze Skala czasu kliknij opcję w polu Skala czasu:

      Brak Powoduje użycie osi kategorii wykorzystującej daty jako etykiet tekstowych zamiast osi skali czasu.

      Automatycznie Na wykresie będzie użyta najbardziej odpowiednia oś skali czasu, a Rozmiar grupy (czyli grupowanie dat według dni, miesięcy, kwartałów itd) będzie określony na podstawie skali osi.

      Ręcznie Na wykresie będzie użyta oś skali czasu, ale użytkownik określa najodpowiedniejszy Rozmiar grupy (czyli grupowanie według dni, miesięcy, kwartałów itd) dla osi na podstawie danych.

    4. W przypadku wybrania opcji Automatycznie lub Ręcznie w poprzednim kroku, należy również określić sposób wyświetlania i sumowania dat w pozostałych opcjach obszaru Skala czasu.

    Odwracanie kierunku wartości na osi

    1. Kliknij oś, której kierunek wartości chcesz odwrócić.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skala.

    3. W obszarze Kolejność zaznacz pole wyboru Pokaż wartości w kolejności odwrotnej.

    Dzielenie wartości na skali osi

    Jeżeli na wykresie znajdują się bardzo małe i bardzo duże wartości, to można tak podzielić oś wartości (lub oś skali czasu), aby wszystkie wartości były wyraźnie widoczne. Na przykład jeżeli wartości należą do zakresu od 0 do 950, przy czym większość z nich mieści się pomiędzy 0 i 100 oraz pomiędzy 750 i 950, to można tak podzielić oś, aby miała dwie skale: dolną dla zakresu od 0 do 100, a górną dla zakresu od 750 do 950, dzięki czemu wyeliminowany zostanie zbędny obszar wykresu pomiędzy 100 i 750.

    Wykres z podzieloną osią

    1. Kliknij oś wartości, którą chcesz podzielić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Oś.
    3. Zaznacz pole wyboru Podział osi, wpisz wartość w polu Podział rozpoczyna się w (które oznacza koniec pierwszej skali), a następnie wpisz wartość w polu Podział kończy się w (które oznacza początek drugiej skali).

    Zmienianie grubości linii lub koloru osi

    Można zmienić grubość i kolor linii serii, osi, siatki, trendu, słupków błędów oraz innych typów linii na wykresie.

    1. Kliknij linię, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Linia/Znacznik.
    3. W obszarze Linia zaznacz żądane opcje.

    Zmienianie formatu liczby wartości osi

    1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
    2. Na wykresie zaznacz element, dla którego chcesz zmienić formatowanie liczby, na przykład oś albo etykiety danych.
    3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
    4. W obszarze Format tekstu, w polu Liczba kliknij żądany format.

    Uwaga Nie można zmienić formatu liczby w przypadku etykiet osi kategorii.

    Zmienianie skali osi wartości

    Skala określa zakres wartości na osi, sposób wyświetlania wartości osi, interwały występowania wartości i punkt przecięcia osi z drugą osią.

    1. Kliknij oś wartości, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skala.
    3. Wykonaj co najmniej jedną z następujących czynności:
      • W obszarze Osie przecinające się zaznacz w polu Przecięcie z oś, która ma przecinać się z osią wartości. Aby określić miejsce przecięcia z osią wartości, kliknij pole wyboru Niestandardowe, a następnie wpisz wartość w polu Niestandardowe.
      • Aby określić wartość najniższą lub najwyższą albo obie wartości, które mają być wyświetlane na osi, zaznacz pola wyboru Maksimum niestandardowe i/lub Minimum niestandardowe, a następnie wpisz odpowiednie wartości w sąsiadujących polach.
      • Aby określić interwały między głównymi i/lub pomocniczymi znacznikami osi i liniami siatki, zaznacz pola wyboru Niestandardowa jednostka główna i/lub Niestandardowa jednostka pomocnicza, a następnie wpisz odpowiednie wartości w sąsiadujących polach, aby określić żądane interwały.
      • Aby obliczyć ponownie wartości na osi na podstawie potęgi 10, 2 lub e, zaznacz pole wyboru Skala logarytmiczna, a następnie kliknij potęgę, której chcesz użyć na liście Użyj podstawy.


Dodawanie, usuwanie lub zmienianie tytułów

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

Dodawanie tytułu

  1. Na wykresie kliknij element, do którego chcesz dodać tytuł: obszar roboczy lub oś wykresu.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.

  3. Kliknij przycisk Dodaj tytuł.

Usuwanie tytułu

  1. Kliknij tytuł, który chcesz usunąć.

  2. Naciśnij klawisz DELETE.

Zmienianie tytułu

  1. Kliknij tytuł, który chcesz zmienić.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image].

  3. Wykonaj co najmniej jedną z następujących czynności:

    Zmienianie formatu tekstu

    1. Kliknij kartę Format.

    2. Zaznacz żądane opcje w obszarze Format tekstu.

    Zmienianie położenia osi

    1. Kliknij kartę Format.

    2. W obszarze Położenie, w polu Położenie kliknij pozycję U góry, U dołu, Z lewej lub Z prawej.

    Zmienianie zawartości tytułu

    1. Kliknij kartę Format.

    2. W obszarze Podpis wpisz nowy tytuł w polu Podpis.

    Zmienianie koloru wypełnienia lub obramowania

    1. Kliknij kartę Obramowanie/Wypełnienie.

    2. Zaznacz żądane opcje w obszarze Obramowanie i obszarze Wypełnienie.


Dodawanie, usuwanie lub zmienianie legendy

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Wykonaj jedną z następujących czynności:

    Dodawanie lub usuwanie legendy

    1. Zaznacz obszar roboczy wykresu, klikając pusty obszar poza obszarem kreślenia, ale w granicach wykresu.

    2. Na pasku narzędzi kliknij przycisk Pokaż/Ukryj legendę [image].

    Zmienianie legendy

    1. Kliknij legendę, którą chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image].
    3. Wykonaj jedną z następujących czynności:

    Zmienianie położenia legendy

    1. Kliknij kartę Format.

    2. W obszarze Położenie, w polu Położenie kliknij pozycje U góry, U dołu, Z lewej lub Z prawej.

    Zmienianie grubości lub koloru obramowania i koloru tła

    1. Kliknij kartę Obramowanie/Wypełnienie.

    2. W obszarze Obramowanie zaznacz żądane ustawienia opcji Kolor, Grubość lub Kreska.

    3. W obszarze Wypełnienie zaznacz żądane ustawienia opcji Typ wypełnienia i Kolor.

    Zmienianie czcionki lub rozmiaru tekstu

    1. Kliknij kartę Format.

    2. W obszarze Format tekstu zaznacz żądane opcje.


Dodawanie, usuwanie lub zmienianie etykiet danych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

    Dodawanie etykiet danych

    Typ wykresu skojarzony z zaznaczoną serią danych lub punktem danych określa typ etykiet danych, które można dodać do wykresu.

    1. Zaznacz serię danych, do której chcesz dodać etykiety danych.

    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.

    3. Kliknij przycisk Dodaj etykietę danych [image].

    Uwaga Nie można dodać etykiety danych do pojedynczego punktu danych. Można natomiast, po dodaniu etykiet danych do serii, zaznaczać i usuwać pojedynczo etykiety danych, których nie trzeba wyświetlać. Aby zaznaczyć pojedynczą etykietę danych, należy kliknąć raz na etykiecie danych, aby zaznaczyć wszystkie etykiety w serii, a następnie kliknąć drugi raz na pojedynczej etykiecie danych, którą trzeba usunąć.

    Usuwanie etykiet danych

    1. Kliknij etykietę danych w zestawie etykiet, które chcesz usunąć.

    2. Naciśnij klawisz DELETE.

    Zmienianie etykiet danych

    Zmienianie zawartości etykiet danych

    1. Kliknij etykietę danych w zestawie etykiet, które chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Etykiety danych.
    3. W obszarze Etykieta danych zaznacz co najmniej jeden z następujących elementów, które można pokazywać w etykiecie danych: Nazwa kategorii, Wartość, Nazwa serii, Rozmiar bąbelka (dostępny tylko w przypadku wykresów bąbelkowych) lub Wartość procentowa.
    4. W przypadku zaznaczenia więcej niż jednego z powyższych elementów do pokazania w etykietach danych, można je rozdzielić średnikiem lub spacją albo każdy umieścić w osobnym wierszu. W tym celu kliknij żądaną opcję na liście Separator.

    Zmienianie formatu tekstu etykiet danych

    1. Kliknij etykietę danych w zestawie etykiet, które chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
    3. Zaznacz żądane opcje w obszarze Format tekstu.

    Zmienianie położenia etykiet danych

    1. Kliknij etykietę danych w zestawie etykiet, które chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Etykiety danych.
    3. W obszarze Etykieta danych, na liście Położenie kliknij miejsce, w którym mają pojawiać się etykiety danych względem znaczników danych. Na przykład kliknij pozycje Podstawa wewnętrzna, aby pokazać etykiety danych wewnątrz i u dołu znaczników danych na standardowym wykresie kolumnowym.

    Zmienianie obramowania lub wypełnienia etykiet danych

    1. Kliknij etykietę danych w zestawie etykiet, które chcesz zmienić.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Obramowanie/Wypełnienie.
    3. Zaznacz żądane opcje w obszarze Obramowanie i obszarze Wypełnienie.


Pokazywanie, ukrywanie lub zmienianie linii siatki

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj co najmniej jedną z następujących czynności:

Pokazywanie lub ukrywanie linii siatki

  1. Kliknij oś, dla której chcesz pokazać lub ukryć linie siatki.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Oś.

  3. W obszarze Znaczniki osi i linie siatki zaznacz lub wyczyść jedno lub oba pola wyboru Główne linie siatki lub Pomocnicze linie siatki.

Zmienianie linii siatki

  1. Kliknij linie siatki, które chcesz zmienić.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Linia/Znacznik.

  3. W obszarze Linia zaznacz żądane opcje.


Zmienianie rozmiaru tekstu i czcionki w przypadku elementów wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij tytuł osi, etykiety danych, etykiety wartości R-kwadrat i etykiety równania, tekst legendy, tytuł wykresu lub inne elementy tekstowe na wykresie, które chcesz zmienić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. W obszarze Format tekstu zaznacz żądane opcje.


Zmienianie koloru i grubości linii oraz stylu elementów wykresu

Można zmienić grubość i kolor linii serii, osi, siatki, trendu, słupków błędów oraz innych typów linii na wykresie.

  1. Kliknij linię, którą chcesz zmienić.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Linia/Znacznik.
  3. W obszarze Linia zaznacz żądane opcje.


Zmienianie kolorów obramowań, wypełnień i teł

Można zmienić kolor i grubość obramowania oraz kolor tła obszaru roboczego wykresu, obszaru kreślenia, legendy, pojedynczego znacznika danych, serii znaczników danych, tytułów i innych elementów wykresu, które obsługują obszary wypełnione.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz obszar wykresu lub element, który chcesz zmienić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Obramowanie/Wypełnienie.
  4. Wykonaj jedną z następujących czynności:
    • Aby zmienić kolor, grubość lub styl obramowania, zaznacz żądane opcje w obszarze Obramowanie.
    • Aby zmienić kolor lub wypełnienie tła, zaznacz opcję w obszarze Wypełnienie na liście Typ wypełnienia (Pełny kolor, Deseń, Gradient albo Obraz/Tekstura), a następnie zaznacz opcje dotyczące danego typu. Na przykład po zaznaczeniu opcji Gradient można wybrać liczbę kolorów w gradiencie i styl gradientu albo gradient wstępnie ustawiony.


Obracanie lub przerzucanie obszaru kreślenia

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Kliknij obszar kreślenia, który chcesz zmienić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  4. Wykonaj jedną z następujących czynności:
    • Aby przerzucić obszar kreślenia w poziomie lub w pionie, kliknij przycisk Przerzuć w poziomie [image] lub Przerzuć w pionie [image].

    • Aby obrócić obszar kreślenia zgodnie z ruchem wskazówek zegara lub przeciwnie do ruchu wskazówek zegara, w przyrostach 90 stopni, kliknij przycisk Obróć zgodnie z ruchem wskazówek zegara [image] lub Obróć przeciwnie do ruchu wskazówek zegara [image].


Wyciąganie wycinków w wykresach kołowych lub pierścieniowych

Wykres kołowy z wyciągniętym wycinkiem i wykres pierścieniowy z wyciągniętym pierścieniem

W wykresie pierścieniowym lub skumulowanym kołowym można wyciągać wycinki wyłącznie z zewnętrznego pierścienia.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Wykonaj jedną z następujących czynności:

    • Aby wyciągnąć wszystkie wycinki lub pierścienie, kliknij obszar roboczy wykresu (pusty obszar pomiędzy obszarem kreślenia a granicą wykresu).

    • Aby wyciągnąć jeden wycinek lub pierścień, kliknij raz wycinek danych lub pierścień, aby zaznaczyć serię danych, a następnie kliknij go drugi raz, aby zaznaczyć pojedynczy wycinek lub pierścień.

  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  4. W obszarze Wykres, w polu Wybuch wpisz — jako procent promienia — liczbę określającą odległość między wierzchołkiem wycinka a środkiem pierścienia lub koła.


Obracanie pozycji wycinków na wykresach pierścieniowych lub kołowych

Przykład obróconych wycinków na wykresie kołowym

Kolejność wykreślania serii danych na wykresie kołowym i pierścieniowym zależy od kolejności danych źródłowych. Za pomocą poniższej procedury można obrócić wycinki na wykresie kołowym lub pierścieniowym w zakresie 360 stopni.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  3. Na liście Zaznacz kliknij pozycję Obszar roboczy wykresu.
  4. W obszarze Wykres, w polu Kąt pierwszego wycinka wpisz liczbę z zakresu od 0 do 360, aby określić kąt wyświetlania pierwszego wycinka.


Zmienianie nakładania się lub odstępów znaczników danych na wykresach słupkowych i kolumnowych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.

  2. Kliknij obszar roboczy wykresu (pusty obszar pomiędzy obszarem kreślenia i granicą wykresu).

  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.

  4. Wykonaj jedną z następujących czynności:

    • Aby zmienić nakładanie znaczników danych w każdej kategorii, wpisz liczbę z zakresu od -100 do 100, reprezentującą procentową wartość nakładania, w polu Zakładka. Na przykład po określeniu wartości 100 słupki lub kolumny nakładają się na siebie, a w przypadku wartości -100 pomiędzy każdym słupkiem lub kolumną wyświetlany jest odstęp o szerokości słupka lub kolumny. Po ustawieniu wartości 0 słupki lub kolumny przylegają do siebie.

    • Aby zmienić odstępy pomiędzy kategoriami znaczników danych, wpisz liczbę z zakresu od 0 do 500, reprezentującą procentową szerokość przerwy, w polu Szerokość przerwy. Na przykład po określeniu wartości 0 znaczniki danych stykają się, a po ustawieniu wartości 100 pomiędzy każdym z nich pojawia się przerwa o szerokości jednego słupka lub kolumny.


Serie i kategorie danych — informacje

Serie danych są reprezentowane przez nazwy w legendzie i pojawiają się na wykresie w postaci grup znaczników danych o podobnym kolorze. Jeden punkt z każdej serii danych tworzy kategorię. Kategorie są to więc grupy punktów danych o podobnych właściwościach. Wartości kategorii i serii danych mogą pochodzić zarówno z wierszy, jak i z kolumn danych.

Na przykład dane mogą wyglądać w ten sposób:

Dane w arkuszu kalkulacyjnym

Aby porównać sprzedaż jednostkową w Europie według kwartałów, serie powinny znajdować się w kolumnach, kategorie w wierszach, a wykres powinien wyglądać następująco:

Po określeniu przez użytkownika, że serie mają znajdować w wierszach, na wykresie kategorią będzie Europa, a każdy kwartał utworzy serię:


Zmienianie serii na kategorie lub kategorii na serie

W zależności od tego, które cechy danych mają być porównywane, można zmienić części danych wyświetlane jako kategorie i części wyświetlane jako serie. W poniższym przykładzie porównanie dotyczy krajów (jako kategorii).

Wykres z latami użytymi jako serie danych

W następującym przykładzie porównanie dotyczy lat (jako kategorii).

Wykres z krajami użytymi jako serie danych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Jeśli wykres utworzono na podstawie danych z listy tabeli przestawnej albo danych zewnętrznych, kliknij przycisk Według wiersza/kolumny [image] na pasku narzędzi.
    • Jeśli wykres utworzono na podstawie danych znajdujących się w arkuszu danych, kliknij wykres prawym przyciskiem myszy, w menu skrótów kliknij polecenie Dane, kliknij kartę Arkusz danych, a następnie kliknij przycisk Według wierszy — Według kolumn [image].


Mapowanie kolorów wykresu w celu odróżniania zakresów danych

Można tak formatować znaczniki danych, aby kolory pełne lub gradientowe reprezentowały wartości lub zakresy danych. Na przykład na poniższym wykresie pokazano lokalizację próbek wody i odpowiadające im pomiary odczynu pH odróżnione za pomocą kolorów gradientowych, gdzie wyższe wartości procentowe poziomu odczynu pH przedstawiono za pomocą coraz jaśniejszych kolorów.

Wykres o zmapowanych kolorach

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij serię danych, którą chcesz sformatować.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formatowanie warunkowe.
  4. Zaznacz pole wyboru Warunkowe kolory punktów danych.
  5. Na liście Styl kliknij żądany styl formatowania warunkowego.
    • Gradient trójpunktowy Do odróżniania najmniejszej wartości od zera (lub wartości wskazanej przez użytkownika) oraz zera (lub wskazanej wartości) od wartości największej służą trzy kolory gradientowe.
    • Gradient dwupunktowy Do odróżniania najmniejszej wartości od największej służą dwa kolory gradientowe.
    • Dwusegmentowy pełny Do odróżniania wartości mniejszych od zera (lub wartości wskazanej przez użytkownika) oraz większych od zera (lub wskazanej wartości) służą dwa pełne kolory.
    • Dolne wartości Pełny kolor służy do odróżniania najmniejszych wartości w zakresie.
    • Górne wartości Pełny kolor służy do odróżniania największych wartości w zakresie.
  6. Wybierz opcję Kolor początkowy, Kolor środka lub Kolor końca (jeśli można ją zastosować) obok pola Kolor do reprezentowania zakresów wartości
  7. Aby wskazać wartość, na której ma być oparty dany format warunkowy, wpisz ją w polu Wartość i w razie potrzeby zaznacz pole wyboru %. Na przykład aby sformatować górne 90% wartości, wpisz liczbę 90 w polu wartości, a następnie zaznacz pole wyboru %.
  8. Jeśli wykres utworzono na podstawie danych pochodzących z bazy danych lub listy tabeli przestawnej, to można określić dodatkowe wartości, na których ma się opierać formatowanie warunkowe. Na przykład w przypadku wykreślania danych dotyczących sprzedaży produktów w różnych regionach, można sformatować znaczniki danych na podstawie zestawu dodatkowych danych, takich jak stopa zysku. W tym celu wyczyść pole wyboru Formatowanie warunkowe na podstawie pola wartości danych, a następnie dodaj żądane pole danych do obszaru upuszczania Formatuj dane widocznego na wykresie.


Dodawanie obrazu lub wypełnienia teksturowanego do wykresu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zapoznaj się z Pomocą programu do projektowania.
  2. Zaznacz obszar wykresu, do którego chcesz dodać obraz — na przykład obszar roboczy wykresu, obszar kreślenia lub znacznik danych.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Obramowanie/Wypełnienie.
  4. W obszarze Wypełnienie, na liście Typ wypełnienia kliknij opcję Obraz/Tekstura.
  5. Wykonaj jedną z następujących czynności:

    Dodawanie własnego obrazu

    1. Kliknij przycisk URL i wpisz lokalizację i nazwę obrazu, którego chcesz użyć.

      W przypadku lokalizacji możesz użyć adresu sieci Web rozpoczynającego się od prawidłowego protokołu, na przykład:

      http://www.microsoft.com/obrazy/nazwa_obrazu.gif

      lub użyć ścieżki konwencji UNC (Universal Naming Convention), takiej jak:

      \\serwer\folder\nazwa_obrazu.gif

      albo ścieżki do pliku na dysku twardym, takiej jak:

      C:\nazwa_obrazu.gif

    2. Naciśnij klawisz ENTER.
    3. Obok pola Format kliknij żądaną opcję wyglądu obrazu na wykresie.
      • Sąsiadująco Kopie obrazu są wyświetlane obok siebie, tak aby wypełniły wybrane miejsce.
      • Rozciągnij Obraz jest rozciągany, tak aby wypełnić całe wybrane miejsce.
      • Ułóż w stos Kopie obrazu są układane w stos, tak aby zapełnić wybrane miejsce.
      • Ułóż w stos według skali Układa kopie obrazu w stos zgodnie z liczbą jednostek osi wartości określoną w polu jednostki. Na przykład, jeśli znacznik danych na wykresie kolumnowym odpowiada wartości 6000 na osi wartości, a jednostki mają odpowiadać wartości 1000, na znaczniku danych zostanie ułożonych w stos sześć obrazów.
      • Rozciągnij wykres Rozciąga obraz na cały wykres, ale wypełnia jedynie zaznaczone elementy.
    4. Jeśli wybierasz opcję Ułóż w stos według skali, wpisz żądaną liczbę jednostek, które ma wypełniać obraz, w polu jednostki, a następnie naciśnij klawisz ENTER.

    Dodawanie tekstury wbudowanej

    • Kliknij przycisk Ustawienie wstępne i kliknij teksturę, której chcesz użyć, na liście Ustawienie wstępne.


Zmienianie widoku wykresu 3-W

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  3. W obszarze Polecenia ogólne, w polu Zaznacz kliknij pozycję Obszar roboczy wykresu.
  4. Kliknij kartę Widok 3-W.
  5. Kliknij żądany Tryb rzutowania:

    Perspektywa [image] Obiekty wykresu są przedstawiane we względnej odległości i w pozycjach, w których mogłoby je postrzegać oko ludzkie.

    Prostopadle [image] Obiekty wykresu są przedstawione, jakby wyglądałyby w tym samym planie, na powierzchni prostopadłej zarówno do linii wzroku, jak i linii rzutu.

  6. Wprowadź żądane zmiany, przeciągając suwaki każdej opcji. Na przykład, aby obrócić źródło oświetlenia wykresu, przeciągnij suwak obrotu [image] w obszarze Oświetlenie.

Uwagi

  • Aby wrócić do domyślnego widoku wykresu, kliknij przycisk Domyślny [image] obok napisu Widok domyślny.
  • Aby współczynniki wysokości lub głębi były proporcjonalne, zaznacz pole wyboru Współczynnik wysokości lub Współczynnik głębi.


Formaty liczby

Część zawartości tego tematu może nie dotyczyć niektórych języków.

Składnik Wykres Microsoft Office korzysta z ustawień regionalnych skonfigurowanych w Panelu sterowania systemu Windows, które określają sposób wyświetlania formatu liczby, waluty, daty i czasu zarówno w programie do projektowania, jak i w czasie wykonania w przeglądarce. Na przykład powyższe ustawienia określają, czy lata są wyświetlane w postaci dwucyfrowej czy czterocyfrowej. Aby uzyskać informacje dotyczące formatów, zobacz Pomoc systemu Windows.

W języku Microsoft Visual Basic lub w skrypcie można przypisać danym niestandardowe formaty liczby. Aby uzyskać więcej informacji, zobacz Pomoc dotyczącą pisania skryptów i programów używających wykresów w sieci Web.

Poniższe formaty liczb są dostępne na liście Format liczby w obszarze Format tekstu, na karcie Format okna dialogowego Polecenia i opcje, które wyświetla się po zaznaczeniu na wykresie takiego elementu, jak wartość osi albo etykieta danych.

Format | Efekty
Ogólny | Wyświetla liczbę bez separatora tysięcy, poprzedzoną znakiem minus w przypadku liczb ujemnych. Na przykład -36 403. Wyświetla maksymalnie 11 cyfr lub 10 cyfr z przecinkiem dziesiętnym, zaokrąglając dodatkowe cyfry po prawej stronie przecinka dziesiętnego. Liczby mające więcej niż 11 cyfr po lewej stronie przecinka dziesiętnego są wyświetlane w formacie naukowym. Wyświetla liczby wyrównane do prawej i tekst wyrównany do lewej.
Data ogólna | Wyświetla liczbę kolejną jako datę i/lub godzinę. Na przykład liczba 36 403,24583 jest wyświetlana jako 31-8-99 05:54 AM. Ułamkowa część liczby jest interpretowana jako godzina. Jeżeli liczba nie ma części ułamkowej, to wyświetlana jest wyłącznie data. Na przykład liczba 35 920 pojawi się w postaci 5-5-98. Jeżeli liczba ma wyłącznie część ułamkową, to wyświetlana jest tylko godzina. Na przykład liczba 0,77 pojawi się w postaci 6:28 PM.
Data długa | Wyświetla datę zgodnie z ustawieniem regionalnym systemu Windows dla formatu daty długiej. Na przykład czwartek, 25 stycznia, 2001.
Data średnia | Wyświetla datę zgodnie z ustawieniami regionalnymi miesięcy i separatora daty w Panelu sterowania systemu Windows, a rok wyświetla w postaci dwucyfrowej. Na przykład 25-sty-01.
Data krótka | Wyświetla datę zgodnie z ustawieniami regionalnymi w Panelu sterowania systemu Windows dla formatu daty krótkiej. Na przykład 25-1-01.
Godzina długa | Wyświetla godzinę zgodnie z ustawieniami regionalnymi w Panelu sterowania systemu Windows dla formatu godziny długiej. Na przykład 20:45:36.
Godzina średnia | Wyświetla godzinę w formacie 12-godzinnym ze znacznikiem AM lub PM z pominięciem sekund. Na przykład 8:45 PM.
Godzina krótka | Wyświetla godzinę w formacie 24-godzinnym, z pominięciem sekund i określenia AM lub PM. Na przykład godzina 8:45 po południu jest wyświetlana jako 20:45.
Waluta | Wyświetla liczbę zgodnie z regionalnymi ustawieniami waluty w Panelu sterowania systemu Windows, z symbolem waluty i separatorem tysięcy, jeżeli jest on potrzebny i z dwoma miejscami po przecinku. Na przykład 2 532,75 zł.
Waluta euro | Wyświetla liczbę jako walutę euro, z separatorem tysięcy i dwoma miejscami po przecinku. Znak euro jest umieszczony przed lub za liczbą, zgodnie z ustawieniami regionalnymi waluty w Panelu sterowania systemu Windows. Na przykład, zgodnie z domyślnymi ustawieniami regionalnymi dla języka polskiego, będzie to 12,35 [image] .
Stały | Wyświetla liczbę z dwoma miejscami dziesiętnymi. Na przykład liczba 68,3 jest wyświetlana jako 68,30.
Standardowy | Wyświetla liczbę z dwoma miejscami dziesiętnymi i separatorem tysięcy określonym przez ustawienia regionalne w Panelu sterowania systemu Windows. Na przykład liczba 1800 pojawia się w postaci 1 800,00.
Procentowy | Wyświetla liczbę pomnożoną przez 100, z dwoma miejscami dziesiętnymi i znakiem procent. Na przykład liczba 0,8914 będzie wyświetlana jako 89,14%.
Naukowy | Liczba jest wyświetlana w notacji wykładniczej. Na przykład 1,25E+10.
Tak/Nie | Wyświetla wartość Nie, jeżeli liczba jest równa 0, a wyraz Tak w przypadku każdej innej liczby.
Prawda/Fałsz | Wyświetla wartość Fałsz, jeżeli liczba jest równa 0, a wartość Prawda w przypadku każdej innej liczby.
Wł/Wył | Wyświetla wartość Wył, jeżeli liczba jest równa 0, a wartość Wł w przypadku każdej innej liczby.


Zmienianie formatowania liczby

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na wykresie zaznacz element, dla którego chcesz zmienić formatowanie liczby, na przykład oś albo etykiety danych.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. W obszarze Format tekstu, w polu Liczba kliknij żądany format.

Uwaga Nie można zmienić formatu liczby w przypadku etykiet osi kategorii.


Używanie dat w wykresach — informacje

Podczas tworzenia wykresu na podstawie danych korzystających z dat, które tworzą oś kategorii (x) na wykresie, można użyć osi kategorii skali czasu do przedstawiania okresu pomiędzy datami.

Wyświetlanie dat Na osi kategorii skali czasu daty są wyświetlane w kolejności chronologicznej w określonych interwałach, nawet jeśli daty nie są rozmieszczone w danych w takich interwałach.

Rozmiar grupy skali czasu (dni, tygodnie, miesiące, kwartały lub lata) początkowo jest ustawiony na wykresie zgodnie z zakresem dat w danych. Na przykład, jeśli rozmiar grupy jest początkowo ustawiony na miesiące, to można go zmienić na kwartały, aby uzyskać inną perspektywę. Po wprowadzeniu zmiany punkty w każdej grupie są automatycznie sumowane, a na wykresie będzie wykreślony jeden punkt dla każdej grupy, tak jak w poniższym przykładzie, w którym punkty w każdym kwartale zostały zsumowane, a wykreślono ich łączną wartość. Można zmienić funkcję podsumowania używaną do tworzenia sum grupowych.

Wykres z osią skali czasu

Wykresy ze skalą czasu i godziny Nie można tworzyć wykresów ze skalą czasu na podstawie danych mierzonych w interwałach godzin, minut lub sekund. Tylko dni, tygodnie, miesiące, kwartały i lata są uwzględniane na wykresach ze skalą czasu.

Typy wykresów umożliwiających użycie osi skali czasu Osie skali czasu są dostępne na wykresach giełdowych i wykresach 2-W oraz 3-W liniowych, kolumnowych, słupkowych i warstwowych, z wyjątkiem przypadków, gdy na wykresach znajdują się wielopoziomowe etykiety kategorii albo pola.

Uwaga Nie można używać osi skali czasu, jeśli daty pojawiają się w legendzie wykresu. Można jednak tak zmienić sposób kreślenia danych na wykresie, aby daty były wyświetlane na osi kategorii.


Linie trendu — informacje

Linie trendu służą do wyświetlania w postaci graficznej trendów danych i analizy problemów związanych z prognozami. Taka analiza nazywana jest również analizą regresji. Na przykład na poniższym wykresie użyto prostej liniowej linii trendu dla czterech kwartałów, aby wyraźnie pokazać wzrost przychodów.

Wykres z liniową linią trendu

Typy wykresów obsługujące linie trendu Linie trendu można dodać do serii danych na wykresie kolumnowym, słupkowym, liniowym, punktowym (xy), bąbelkowym, warstwowym, giełdowym i polarnym. W przypadku zmiany typu wykresu na typ, który nie obsługuje skojarzonej linii trendu, linie trendu zostaną utracone.

Używanie wartości R-kwadrat do określania najlepszej linii trendu

Chcąc dodać linię trendu do wykresu, można wybrać jeden z pięciu różnych typów trendów/regresji. Typ danych określa typ linii trendu, który należy użyć.

Wiarygodność linii trendu i wartość R-kwadrat Linia trendu jest najbardziej wiarygodna, gdy odpowiadająca jej wartość R-kwadrat jest równa lub niemal równa 1. Wartość R-kwadrat, nazywana również współczynnikiem określoności, jest wskaźnikiem o wartości z zakresu od 0 do 1, który mówi, w jakim stopniu przybliżone wartości otrzymane na podstawie linii trendu odpowiadają danym rzeczywistym. Z chwilą dopasowania linii trendu do danych automatycznie jest obliczana wartość R-kwadrat. Można ją wyświetlić na wykresie.

Liniowe linie trendu

Liniowa linia trendu to optymalnie dopasowana linia prosta używana dla prostych, liniowych zbiorów danych. Dane są liniowe, gdy układ punktów danych przypomina linię prostą. Liniowa linia trendu zazwyczaj oznacza, że coś rośnie lub maleje ze stałą szybkością.

W poniższym przykładzie liniowa linia trendu wyraźnie pokazuje, że sprzedaż lodówek nieprzerwanie rosła w ciągu 13 lat. Należy zauważyć, że wartość R-kwadrat jest równa 0,9036, co wskazuje na dobre dopasowanie linii do danych.

Liniowa linia trendu

Logarytmiczne linie trendu

Logarytmiczna linia trendu to optymalnie dopasowania linia krzywa, która jest najbardziej użyteczna, gdy szybkość zmian danych szybko rośnie lub maleje, a następnie stabilizuje się. Logarytmiczną linię trendu można stosować dla wartości ujemnych i dodatnich.

W poniższym przykładzie użyto logarytmicznej linii trendu do zilustrowania przewidywanego wzrostu populacji zwierząt na ograniczonym obszarze, na którym populacja stabilizuje się na skutek ograniczonej ilości miejsca. Należy zauważyć, że wartość R-kwadrat jest równa 0,9407, co wskazuje na stosunkowo dobre dopasowanie linii do danych.

Logarytmiczna linia trendu

Wielomianowe linie trendu

Wielomianowa linia trendu to krzywa używana dla fluktuujących danych. Jest ona przydatna np. do analizowania zysków i strat na dużym zbiorze danych. Stopień wielomianu można określić na podstawie liczby fluktuacji danych lub na podstawie liczby zgięć (wzniesień i zagłębień) pojawiających się na krzywej. Wielomianowa linia trendu stopnia 2 ma zawsze tylko jedno wzniesienie lub zagłębienie. Wielomian stopnia 3 ma jedno lub dwa wzniesienia i zagłębienia. Stopień 4 ma do trzech wzniesień lub zagłębień.

W poniższym przykładzie pokazano wielomianową linię trendu 2 stopnia (z jednym wzniesieniem) ilustrującą związek między szybkością i zużyciem benzyny. Należy zauważyć, że wartość R-kwadrat jest równa 0,9474, co wskazuje na dobre dopasowanie linii do danych.

Wielomianowa linia trendu

Potęgowe linie trendu

Potęgowa linia trendu to linia krzywa optymalna dla zbiorów danych porównujących pomiary rosnące z określoną szybkością — na przykład całkowita droga przebyta przez przyspieszający samochód wyścigowy w odstępach 1-sekundowych. Potęgowej linii trendu należy używać, gdy dane zawierają wartości większe od 0 (zera). W przypadku utworzenia potęgowej linii trendu za pomocą danych zawierających wartość 0 lub wartości ujemne w etykiecie równania na wykresie pojawi się komunikat „Błąd linii trendu".

W poniższym przykładzie dla przyspieszającego samochodu wyścigowego wykreślono przebytą drogę w metrach na sekundę. Potęgowa linia trendu wyraźnie pokazuje rosnące przyspieszenie. Należy zauważyć, że wartość R-kwadrat jest równa 0,9923, co wskazuje na prawie idealne dopasowanie linii do danych.

Potęgowa linia trendu

Wykładnicze linie trendu

Wykładnicza linia trendu to linia krzywa, która jest najbardziej przydatna, gdy wartości danych rosną lub maleją ze wzrastającą szybkością. Należy używać wykładniczej linii trendu, gdy dane zawierają wartości większe od 0. W przypadku utworzenia wykładniczej linii trendu za pomocą danych zawierających wartość 0 lub wartości ujemne w etykiecie równania na wykresie pojawi się komunikat „Błąd linii trendu”.

W poniższym przykładzie wykładnicza linia trendu została użyta do zilustrowania malejącej ilości izotopu węgla 14 wraz ze starzeniem się obiektu. Należy zauważyć, że wartość R-kwadrat jest równa 1, co wskazuje na idealne dopasowanie linii do danych.

Wykładnicza linia trendu

Średnia ruchoma

Linia trendu średniej ruchomej wygładza fluktuacje danych, aby wyraźniej pokazać wzór lub trend. Średnia ruchoma używa określonej liczby punktów danych (ustawionej za pomocą opcji Okres), uśrednia je i używa średnich wartości jako punktów na linii. Na przykład jeżeli wartość Okres jest ustawiona na 2, to jako pierwszy punkt linii trendu średniej ruchomej zostanie użyta średnia dwóch pierwszych punktów. Średnia drugiego i trzeciego punktu danych zostanie użyta jako drugi punkt linii trendu itd.

W poniższym przykładzie linia trendu średniej ruchomej pokazuje wzór w liczbie sprzedanych domów w czasie 26 tygodni.

Linia trendu średniej ruchomej


Równania służące do obliczania linii trendu

Liniowa

Oblicza przystawanie najmniejszych kwadratów dla linii reprezentowanej przez następujące równanie:

gdzie m to nachylenie, a b to punkt przecięcia z osią.

Wielomianowa

Oblicza przystawanie najmniejszych kwadratów do punktów za pomocą następującego równania:

gdzie b i Zmienna są stałymi.

Logarytmiczna

Oblicza przystawanie najmniejszych kwadratów do punktów za pomocą następującego równania:

gdzie c i b są stałymi, a ln jest funkcją logarytmu naturalnego.

Wykładnicza

Oblicza przystawanie najmniejszych kwadratów do punktów za pomocą następującego równania:

gdzie c i b są stałymi, a e jest podstawą logarytmu naturalnego.

Potęgowa

Oblicza przystawanie najmniejszych kwadratów do punktów za pomocą następującego równania:

gdzie c i b są stałymi.

Średnia ruchoma

Uwaga Liczba punktów linii trendu średniej ruchomej jest równa całkowitej liczbie punktów w serii pomniejszonej o liczbę podaną jako okres.

Wartość R-kwadrat

Wartość R-kwadrat, nazywana również współczynnikiem określoności, jest wskaźnikiem z zakresu wartości od 0 do 1, który wskazuje, w jakim stopniu szacowane wartości otrzymane na podstawie linii trendu odpowiadają rzeczywistym danym. Linia trendu jest najbardziej wiarygodna, gdy odpowiadająca jej wartość R-kwadrat jest bliska 1. Po dopasowaniu linii trendu do danych składnik Wykres pakietu Microsoft Office Web Component automatycznie oblicza wartość R-kwadrat dla linii trendu za pomocą następującego równania:

Uwaga Wartość R-kwadrat, którą można wyświetlić z linią trendu, nie jest dostosowaną wartością R-kwadrat. Dla logarytmicznych, potęgowych i wykładniczych linii trendu składnik Wykres Microsoft Office używa transformowanego modelu regresji.


Dodawanie linii trendu do serii danych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij serię danych, do której chcesz dodać linię trendu.
  3. Na pasku narzędzi wykresu kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  4. W obszarze Dodaj kliknij przycisk Dodaj linię trendu [image].

Uwaga Liniowa linia trendu, jej równanie oraz wartość R-kwadrat są umieszczane na seriach. Pozostałe typy linii trendu to linie logarytmiczna, wielomianowa, potęgowa, wykładnicza i średniej ruchomej.


Zmienianie linii trendu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij linię trendu, którą chcesz zmienić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Linia trendu.
  4. Wykonaj co najmniej jedną z następujących czynności:
    • Aby zmienić typ linii trendu, kliknij strzałkę obok pola Typ i zaznacz typ na liście.

    • Aby zmienić kolejność wielomianowej linii trendu, kliknij strzałkę obok pola Kolejność i wybierz z listy liczbę, która ma być największą potęgą zmiennej niezależnej.

    • Aby zmienić wyświetlaną w legendzie nazwę linii trendu, kliknij pole wyboru Nazwa niestandardowa w obszarze Nazwa, a następnie wpisz nową nazwę w polu po prawej stronie.

    • Aby pokazać lub ukryć równanie używane do obliczania linii trendu, zaznacz lub wyczyść pole wyboru Wyświetl równanie.

    • Aby pokazać lub ukryć wartość R-kwadrat, zaznacz lub wyczyść pole wyboru Wyświetl wartość R-kwadrat.


Usuwanie linii trendu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij linię trendu, którą chcesz usunąć.
  3. Naciśnij klawisz DELETE.


Pokazywanie lub ukrywanie równania lub wartości R-kwadrat linii trendu

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij linię trendu, dla której chcesz wyświetlić lub ukryć równanie lub wartość R-kwadrat.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Linia trendu.
  4. W obszarze Równanie zaznacz lub wyczyść pola wyboru Wyświetl równanie oraz Wyświetl wartość R-kwadrat albo oba.


Słupki błędów — informacje

Słupki błędów wyrażają graficznie potencjalną wielkość błędu w stosunku do poszczególnych znaczników danych w serii danych. Na przykład można pokazać potencjalne 5-procentowe błędy dodatnie i ujemne w wynikach eksperymentu naukowego:

Wykres ze słupkami błędów

Typy wykresów obsługujące słupki błędów Można dodać słupki błędów do serii danych na wykresie kolumnowym, słupkowym, liniowym, punktowym (xy), bąbelkowym, warstwowym, radarowym, giełdowym i polarnym. Na wykresach punktowych (xy), polarnych i bąbelkowych można wyświetlić słupki błędów dla wartości x lub wartości y. W przypadku zmiany typu wykresu na typ nieobsługujący skojarzonych słupków błędów, będą one utracone.


Równania służące do obliczania wielkości błędów w słupkach błędów

Odchylenie standardowe

gdzie:

s = numer serii

i = numer punktu w serii s

m = liczba serii dla punktu y na wykresie

n = liczba punktów w każdej serii

Zmienna = wartość danej w i-tym punkcie serii s

Zmienna = całkowita liczba wartości danych we wszystkich seriach

M = średnia arytmetyczna

Błąd standardowy

gdzie:

s = numer serii

i = numer punktu w serii s

m = liczba serii dla punktu y na wykresie

n = liczba punktów w każdej serii

yis = wartość danych w i-tym punkcie serii s

ny = całkowita liczba wartości danych we wszystkich seriach


Dodawanie słupków błędów do serii danych

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij serię danych, do której chcesz dodać słupki błędów.
  3. Na pasku narzędzi wykresu kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  4. W obszarze Dodaj kliknij przycisk Dodaj słupek błędu [image].


Zmienianie słupków błędów

Po zaznaczeniu słupka błędu wszystkie wprowadzone zmiany wpływają na wszystkie słupki błędów w skojarzonej serii danych.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij dowolny słupek błędu na wykresie.
  3. Na pasku narzędzi wykresu kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Słupki błędów.
  4. Wykonaj co najmniej jedną z następujących czynności:
    • Aby pokazać lub ukryć zakończenia słupków błędów, kliknij strzałkę obok pola Wyświetl [image], a następnie kliknij żądany typ.

    • Aby wybrać inny typ słupka błędu (dodatni, ujemny lub oba), kliknij strzałkę obok pola Znacznik [image], a następnie kliknij żądany typ.

    • Aby zmienić metodę używaną do określenia wielkości błędu, kliknij odpowiednią metodę na liście Obliczanie błędu, a następnie wpisz żądaną liczbę w polu Błąd lub w polu Wartość procentowa.

    • Aby zmienić kierunek słupków błędów w celu ich obliczania na podstawie wartości x lub wartości y na wykresach punktowych (xy), polarnych i bąbelkowych, kliknij pozycję X lub Y na liście Kierunek.


Usuwanie słupków błędów

Nie można usunąć pojedynczego słupka błędu. Usunięcie jednego słupka błędu powoduje usunięcie wszystkich słupków błędów dla całej serii danych.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij dowolny słupek błędu w serii, z której chcesz usunąć słupki błędów.
  3. Naciśnij klawisz DELETE.


Filtrowanie danych na wykresie — informacje

Funkcji filtrowania można użyć w celu znalezienia określonych wartości danych albo wszystkich danych odpowiadających pewnej wartości. Można filtrować podczas projektowania wykresu oraz po wyświetleniu go w przeglądarce, jeżeli nie ograniczono dostępu do filtrowania.

Techniki filtrowania

Filtrowanie pola (autofiltrowanie) Można filtrować pola w obszarach kategorii, serii i filtru. Aby filtrować pole, należy zaznaczyć co najmniej jeden element danych w tym polu, który ma być widoczny, i ukryć pozostałe elementy.

Filtrowanie pola jest szczególnie pomocne, jeśli jest duża ilość danych źródłowych, lecz trzeba się skupić na określonych obszarach. Podczas filtrowania pola można wyświetlić dane dla pojedynczego elementu lub wybrać jedne elementy do wyświetlenia, a inne do ukrycia. Aby zawęzić obszar zainteresowania, można filtrować kilka pól jednocześnie.

Wykres z polem kategorii

Wykres z filtrowanym polem kategorii

1 Pole kategorii Region z wyświetlonymi wszystkimi elementami (bez filtrowania)

2 Filtrowane pole kategorii Region, w którym pokazano regiony Południowy i Zachodni

Filtrowanie warunkowe Można zastosować filtr do serii lub punktów, aby pokazać górne lub dolne n elementów na podstawie sumy. Na przykład można zastosować filtrowanie, aby wyszukać trzy miasta, w których wygenerowano największą wartość sprzedaży lub pięć produktów, które przyniosły najmniejszy zysk. Zamiast n można także wybrać filtrowanie pewnego procentu elementów. Na przykład można filtrować 25% najlepszych lub najgorszych sprzedawców na podstawie liczby zrealizowanych zamówień. Jeśli jest 40 sprzedawców, to po zastosowaniu filtru zostaną wyświetlone dane 10 osób.

Łączenie wielu filtrów

Filtry można dodawać. Każdy zastosowany filtr jest dodawany do filtrów już działających.

Usuwanie i ponowne stosowanie filtru

Po wyłączeniu autofiltrowania można wyświetlić wszystkie dane we wszystkich polach. Ustawienia filtrowania są zachowywane, więc po ponownym włączeniu autofiltrowania te same dane będą wyświetlone lub ukryte.

Ustawienia filtru są zachowywane podczas przenoszenia pól w celu zmiany układu. Jeśli użytkownik usunie pole, a następnie doda je ponownie do układu, to te same elementy zostaną znów ukryte.

Nie chcąc zachowywać zaznaczeń filtru, przed rozpoczęciem zaznaczania elementów do filtrowania należy się upewnić, że przycisk Autofiltr [image] nie jest zaznaczony. Jeżeli przycisk nie jest zaznaczony, to wybranie nowych elementów do filtrowania automatycznie włączy filtrowanie i usunie wcześniejsze ustawienia filtru.

Identyfikowanie aktualnie działających filtrów

Jeśli elementy w polu są ukryte na skutek autofiltrowania, to strzałka rozwijania Strzałka pola na etykiecie pola jest niebieska. Należy kliknąć niebieską strzałkę [image], aby zobaczyć działający filtr.

Ograniczanie filtrowania w przeglądarkach

Aby użytkownicy nie mogli zmienić sposobu filtrowania danych, można uniemożliwić im dostęp do funkcji filtrowania w czasie uruchomienia.


Filtrowanie pola na wykresie

Filtrowanie pola w obszarze kategorii, serii lub filtru (autofiltrowanie)

Jeśli w obszarze filtru nie ma pola, to można dodać do niego nowe pole albo przenieść tu pole z innego obszaru.
  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij strzałkę Strzałka pola pola zawierającego elementy danych, które chcesz filtrować.
  3. Zaznacz pola wyboru dla elementów, które chcesz wyświetlać i wyczyść pola wyboru dla elementów, które chcesz ukryć.

Uwagi

  • Aby wyświetlić lub ukryć wszystkie dane pola, zaznacz lub wyczyść pole wyboru (Wszystkie). Wycieniowane pole wyboru wskazuje, że niektóre elementy są ukryte.
  • Pole umieszczone w obszarze kategorii, serii lub filtru zawsze obsługuje wybór wielokrotny. Pole w obszarze filtru może obsługiwać albo wybór pojedynczy, albo wybór wielokrotny.

Filtrowanie serii lub punktu w celu znalezienia określonej liczby, górnych lub dolnych, n wartości albo wartości procentowej (filtrowanie warunkowe)

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole, serię lub punkt zawierający wartości, które chcesz filtrować.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje Strzałka pola, a następnie kliknij kartę Filtr i grupa.
  4. W polu Wyświetl kliknij pozycję Górny lub Dolny.
  5. W polu Elementy ustaw liczbę z listy albo wpisz żądaną wartość.
  6. Aby pokazać n elementów, wyczyść pole wyboru %. Aby pokazać n% elementów, zaznacz pole wyboru %.
  7. W polu Oparty na ustaw wartość z listy.


Usuwanie filtrów w celu wyświetlenia wszystkich danych na wykresie

Jeśli elementy pola są ukryte na skutek filtrowania, to strzałka Strzałka pola na etykiecie pola jest niebieska.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:

    Usuwanie wszystkich filtrów

    • Kliknij przycisk Autofiltr [image] na pasku narzędzi, aby nie był zaznaczony.

    Uwaga Po ponownym kliknięciu przycisku Autofiltr [image] w celu włączenia filtrowania poprzednio ustawione filtry zostaną znów zastosowane.

    Usuwanie autofiltru z pola

    1. Kliknij niebieską strzałkę [image] pola, z którego chcesz usunąć filtr.
    2. Zaznacz pole wyboru (Wszystkie), a następnie kliknij przycisk OK.

    Usuwanie filtru warunkowego

    1. Zaznacz serię lub punkt, z których chcesz usunąć filtrowanie warunkowe.
    2. Kliknij przycisk Pokaż górne/dolne elementy [image] na pasku narzędzi, a następnie kliknij przycisk Pokaż wszystko.
Uwagi
  • Nie chcąc zachowywać filtrów, należy upewnić się przed rozpoczęciem zaznaczania elementów do filtrowania, że przycisk Autofiltrowanie nie jest wciśnięty. Jeżeli przycisk nie jest zaznaczony, to wybranie nowych elementów do filtrowania automatycznie włączy filtrowanie i usunie wcześniejsze ustawienia filtru.
  • Można uniemożliwić użytkownikom usuwanie filtrów w przeglądarce, czyszcząc pole wyboru Zezwalaj na filtrowanie przestawne na karcie Pokaż/Ukryj w oknie dialogowym Polecenia i opcje.


Zezwalanie na wielokrotny lub pojedynczy wybór pola w obszarze filtru

Można określić, czy pole w obszarze filtru ma obsługiwać wybór pojedynczy, czy też wielokrotny. W trybie pojedynczego wyboru zaznaczenie jakiegoś elementu powoduje automatycznie wyczyszczenie poprzedniego zaznaczenia. Po zaznaczeniu jakiegoś elementu w trybie wielokrotnego wyboru zaznaczone wcześniej elementy pozostają wybrane.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole, którego ustawienie chcesz zmienić. Pole nie powinno jeszcze znajdować się w obszarze filtru, lecz w jednym z innych obszarów na wykresie, na przykład w obszarze serii lub kategorii.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Filtr i grupa.
  4. Zaznacz lub wyczyść pole wyboru Zezwalaj na zaznaczanie wielu elementów w obszarze filtru.

    Po przeniesieniu pola do obszaru filtru będzie on odzwierciedlać nowe ustawienia.

Uwagi

  • Domyślnie wybór wielokrotny jest włączony.
  • Ustawienie to dotyczy jedynie pola znajdującego się w obszarze filtru. Pole przeniesione do obszaru kategorii lub serii zawsze obsługuje wybór wielokrotny.


Rozwijanie lub zwijanie elementów w polach

W polach serii lub kategorii można rozwijać lub zwijać elementy, aby pokazać lub ukryć szczegółowe informacje o konkretnym elemencie. Rozwijanie jest podobne do wchodzenia do wewnątrz jednak z takim wyjątkiem, że elementy na tym samym poziomie nie są ukrywane. W poniższym przykładzie rozwinięto region Zachodni, aby pokazać szczegółowe informacje dotyczące tego regionu, lecz inne regiony są nadal wyświetlane bez szczegółowych informacji. Zwinięcie powoduje usunięcie szczegółowych informacji o danym elemencie i powrót wykresu do stanu sprzed rozwinięcia.

Wykresy z rozwiniętymi i zwiniętymi polami

1 Wykres przedstawiający sprzedaż w każdym regionie.

2 Wykres z rozwiniętym regionem Zachodnim w celu pokazania sprzedaży według produktów w tym regionie.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Kliknij pole zawierające element lub elementy, które chcesz rozwinąć lub zwinąć.
  3. Na pasku narzędzi kliknij przycisk Rozwiń [image] albo Zwiń [image].


Wchodzenie do wewnątrz lub wychodzenie na zewnątrz danych w polu

W polu kategorii zewnętrznej można zejść do elementu, aby się skupić na szczegółowych informacjach dotyczących konkretnego elementu albo wyjść na zewnątrz, aby usunąć szczegółowe informacje dotyczące elementu. Wchodzenie i wychodzenie jest podobne do rozwijania, ale po wejściu do wnętrza elementu inne elementy tego samego poziomu są ukrywane.

W poniższym przykładzie przedstawiono wejście do elementu region Północny, co spowodowało pokazanie szczegółowych informacji o tym regionie i ukrycie wszystkich informacji dotyczących innych regionów. Po wyjściu na zewnątrz elementu szczegółowe informacje są usuwane, a ponownie pokazują się elementy tego samego poziomu.

Wykresy pokazujący informacje po wejściu do wewnątrz

1 Wykres pokazujący informacje o sprzedaży produktów według regionów.

2 Wykres pokazujący region Północny po wejściu do wewnątrz w celu wyświetlenia informacji o sprzedaży każdego typu produktów jedynie w tym regionie. Pozostałe regiony są ukryte.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na osi kategorii kliknij element, do którego chcesz wejść albo z którego chcesz wyjść.
  3. Na pasku narzędzi kliknij przycisk Wejdź do wewnątrz [image] albo Wyjdź na zewnątrz [image].


Sortowanie danych na wykresie

Można sortować dane kategorii i serii na wykresie utworzonym na podstawie listy tabeli przestawnej albo tabeli lub kwerendy bazy danych.

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Wykonaj jedną z następujących czynności:
    • Aby sortować dane liczbowe w seriach, kliknij serię lub punkt serii w obrębie serii.
    • Aby alfabetycznie sortować elementy w polu, kliknij pole kategorii lub serii albo kliknij etykietę osi kategorii lub pozycję legendy.
  3. Wykonaj jedną z następujących czynności:
    • Kliknij przycisk Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi.
    • Chcąc sortować wartości liczbowe w przypadku wykresu skumulowanego słupkowego, skumulowanego warstwowego albo skumulowanego kolumnowego na podstawie wysokości całej wartości skumulowanej, a nie tylko jednej serii, kliknij prawym przyciskiem myszy serię lub punkt, wskaż polecenie Sortuj, a następnie kliknij polecenie Rosnąco według sumy lub Malejąco według sumy.


Grupowanie i rozgrupowywanie danych na wykresie

  1. W oknie projektowania upewnij się, że wykres jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Zaznacz pole kategorii lub serii, którego elementy chcesz zgrupować lub rozgrupować.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Filtr i grupa.
  4. Wykonaj jedną z następujących czynności:

    Grupowanie danych

    1. W obszarze Grupowanie ustaw pole Grupuj elementy według na wartość inną niż (Bez grupowania).
    2. W polu Interwał ustaw żądaną wartość. Możliwy do określenia typ interwału zależy od typu danych pola.
      • Pola liczbowe Można grupować w interwałach według dowolnej liczby całkowitej, takiej jak 1, 2, 5, 100 itd. Na przykład można grupować pole IDPracownika w grupy 1–100, 101–200 itd.
      • Pola daty i czasu Można grupować w interwałach takich jak dni, tygodnie i kwartały. Na przykład można pogrupować wartości w polu DataWysyłki według miesięcy, aby pokazać dane zamówień zrealizowanych w styczniu, w lutym itd.
      • Pola tekstowe Można grupować według pierwszych n znaków poszczególnych elementów. Na przykład można grupować pole Nazwisko według pierwszej litery, aby utworzyć takie grupy jak A, B itd.
    3. Aby określić wartość początkową i końcową grupowania w przypadku wartości liczbowych, zaznacz jedno lub oba pola wyboru Rozpocznij od lub Zakończ na, a następnie wprowadź wartość w sąsiednim polu tekstowym.

    Rozgrupowywanie danych

    • W polu Grupuj elementy według ustaw pozycję (Bez grupowania).


Funkcje podsumowania dostępne w polach danych wykresu

W poniższej tablicy przedstawiono funkcje podsumowania udostępniane za pomocą przycisku Autoobliczanie [image] używanego do podsumowywania pól danych.

Funkcja | Opis
Suma | Oblicza sumę wartości.
Licznik | Zlicza liczbę wartości. Puste wartości, takie jak ciągi o długości zerowej (ciągi, które nie zawierają znaków), są uwzględniane w zliczaniu, ale wartości zerowe (wartości wskazujące brakujące lub nieznane dane) nie są zliczane.
Min | Zwraca najmniejszą wartość w podsumowywanym polu.
Maks | Zwraca największą wartość w podsumowywanym polu.
Średnia | Zwraca średnią wartości w podsumowywanym polu.
Odchylenie standardowe | Zwraca odchylenie standardowe wartości w podsumowywanym polu, przy założeniu, że wartości są próbką z większej populacji.
Odchylenie standardowe populacji | Zwraca odchylenie standardowe wartości w podsumowywanym polu, przy założeniu, że wartości to cała populacja.
Wariancja | Zwraca wariancję wartości w podsumowywanym polu, przy założeniu, że wartości są próbką z większej populacji.
Wariancja populacji | Zwraca wariancję wartości w podsumowywanym polu, przy założeniu, że wartości to cała populacja.

Uwaga Dostępne funkcje podsumowania zależą od typu danych w określonym polu. Na przykład, jeśli pole zawiera tekst, to można w nim używać wyłącznie funkcji Licznik.


Rozwiązywanie problemów z wykresami

Nie mogę znaleźć żądanego polecenia lub opcji.

Jeśli nie możesz znaleźć żądanego polecenia lub opcji w oknie dialogowym Polecenia i opcje, może to wynikać z tego, że na wykresie nie jest zaznaczony niezbędny element. Aby upewnić się, że właściwy element jest zaznaczony, kliknij kartę Ogólne w oknie dialogowym Polecenia i opcje, a następnie kliknij w polu Wybierz element wykresu, z którym chcesz pracować. Opcje tego elementu wykresu pojawią się wówczas w oknie dialogowym Polecenia i opcje.

W lewym dolnym rogu wykresu pojawia się wykrzyknik.

Alert pasywny wskazuje, że dany wykres zawiera błąd. Alert pojawia się w postaci wykrzyknika w dolnym lewym rogu wykresu i po kliknięciu wyświetla informacje na temat alertu. Alerty pasywne pojawiają się w przypadku wystąpienia błędu, na przykład, jeśli nie można znaleźć pliku tekstury lub połączyć się z bazą danych.

  1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ogólne.
  2. W obszarze Polecenia ogólne, w polu Zaznacz kliknij pozycję Obszar roboczy wykresu.
  3. Kliknij kartę Pokaż/Ukryj.
  4. W obszarze Błędy zaznacz lub wyczyść pole wyboru Pokaż alerty pasywne.

Nie mogę przenieść ani zmienić rozmiarów elementów wykresu za pomocą myszy.

Elementów wykresu (takich jak legenda, obszar kreślenia, etykiety danych i tytuły) nie można przenosić ani nie można zmieniać ich rozmiarów za pomocą myszy. Można jednak przenosić elementy wykresu, takie jak legenda i niektóre osie, za pomocą ustawień Pozycja lub Położenie na odpowiednich kartach okna dialogowego Polecenia i opcje. Inne ustawienia w oknie dialogowym Polecenia i opcje umożliwiają obracanie lub przerzucanie obszaru kreślenia wykresu, rozrzucanie wycinków wykresu kołowego lub pierścieniowego, zmienianie rozmiaru czcionki używanej w etykietach, tytułach i legendach oraz zmienianie rozmiarów znaczników danych na niektórych typach wykresów. Rozmiar innych elementów wykresu jest zmieniany automatycznie przy zmianie rozmiaru wykresu.

Nie mogę dodać tekstu do wykresu.

Można dodawać tytuły do wykresu i do osi wykresu. Można również dodawać etykiety danych do znaczników danych. Do wykresu nie można dodawać swobodnego tekstu. Jeżeli jest taka potrzeba, to należy dodać tekst do strony sieci Web, która zawiera wykres.

Brak tekstu przy poziomej osi wykresu (osi x).

Na wykresie może nie być wystarczająco dużo miejsca do wyświetlenia wszystkich etykiet osi. Jeżeli niektóre spośród nazw kategorii przy poziomej osi wykresu są niewidoczne, spróbuj wykonać następujące czynności:

  • Powiększ wykres. Zapoznaj się z Pomocą programu do projektowania, aby dowiedzieć się, jak zaznaczać i zmieniać rozmiary formantu wykres.
  • Użyj do tekstu osi poziomej (osi x) mniejszej czcionki.
  • Skróć nazwy kategorii w danych źródłowych.

Na wykresie punktowym xy nie ma właściwych wartości na osi poziomej (x).

Jeżeli na osi kategorii (x) wyświetlane są liczby, takie jak 1, 2, 3, 4 zamiast żądanych wartości, to być może zamiast wykresu punktowego xy utworzono wykres liniowy. Po uaktywnieniu wykresu w programie do projektowania, kliknij przycisk Typ wykresu [image] na pasku narzędzi, kliknij pozycję Punktowy (XY) na liście na karcie Typ, a następnie kliknij żądany podtyp, którego chcesz użyć, po prawej stronie. Jeżeli chcesz połączyć znaczniki danych liniami, to kliknij jeden z podtypów, które mają takie linie.

Publikuję wykres za pomocą programu Microsoft Excel, ale zawiera on więcej danych niż początkowy wykres w programie Excel

W programie Microsoft Excel można określić, że na wykresie mają być wykreślane tylko widoczne komórki. Jeżeli to ustawienie jest włączone, to na wykresie nie są wyświetlane dane z ukrytych wierszy lub ukrytych kolumn w zakresie danych, który został użyty do utworzenia wykresu. Jednak po opublikowaniu wykresu będą na nim odzwierciedlone wszystkie dane.

Jeżeli nie chcesz, aby na wykresie były wyświetlane ukryte dane, to możesz odkryć wiersze i kolumny w arkuszu i przenieść dane poza zakres używany do utworzenia wykresu przed jego opublikowaniem. Aby uzyskać informacje o przenoszeniu danych w arkuszu, zapoznaj się z Pomocą programu Excel. Aby zmienić wykres po opublikowaniu, możesz odkryć i usunąć wiersze lub kolumny zawierające dane, które mają nie być wyświetlane w arkuszu kalkulacyjnym publikowanym z wykresem. Aby uzyskać informacje o usuwaniu wierszy lub kolumn, zapoznaj się z Pomocą składnika Spreadsheet Component.

Publikuję wykres za pomocą programu Microsoft Excel, ale nie ma na nim żadnych danych, gdy go przeglądam w programie do projektowania lub w przeglądarce.

Aby opublikować wykres w sieci Web za pomocą programu Microsoft Excel, trzeba włączyć do niego zarówno wartości x, jak i y (w przypadku wykresu punktowego xy), a wartości x, y i rozmiary bąbelków w przypadku wykresu bąbelkowego. Jeżeli wartości x nie są włączone do wyboru danych, to program Excel użyje danych domyślnych. Te wartości pojawiają się na wykresie w programie Excel, ale nie są zachowywane po opublikowaniu wykresu jako strony sieci Web.

Jeżeli nie włączono do wykresu wszystkich niezbędnych wartości, to należy je wpisać w programie Excel w kolumnie sąsiadującej z oryginalnymi danymi wykresu, a następnie ponownie utworzyć wykres i ponownie go opublikować.

Na stronie sieci Web, na której powinien znajdować się wykres, jest puste pole

W przeglądarce Można przeglądać i interaktywnie pracować z wykresami dla sieci Web w przeglądarce Microsoft Internet Explorer w wersji 4.01 i w wersjach nowszych. Wykres może być reprezentowany jako puste pole w innych wersjach przeglądarek. W takim przypadku należy zamknąć stronę i otworzyć ją ponownie w programie Internet Explorer w wersji 4.01 lub w wersji nowszej.

W programie do projektowania Opublikowane wykresy można wyświetlać i modyfikować w programach Microsoft FrontPage XP, Microsoft Access XP oraz Microsoft Visual Basic. Wykres może być reprezentowany jako puste pole w innych programach do projektowania.

Użytkownicy nie mogą w przeglądarce wyświetlić wykresu ani nie mogą z nim interaktywnie pracować.

Zainstaluj składniki Microsoft Office Web Components Aby móc przeglądać wykresy przeznaczone do sieci Web i pracować z nimi, użytkownicy muszą mieć zainstalowane składniki Office Web Components. Użytkownicy mogą je zainstalować wraz z pakietem Microsoft Office XP lub, jeżeli ich firma posiada licencję pakietu Microsoft Office XP w trybie dostępu na lokalizację, to mogą je pobrać z firmowej sieci intranet.

Sprawdź wersję przeglądarki Aby pracować interaktywnie z wykresem, użytkownicy potrzebują także programu Microsoft Internet Explorer w wersji 4.01 lub nowszej. Zaleca się, aby użytkownicy posiadali program Internet Explorer 5, aby w pełni wykorzystać interaktywne możliwości wykresu i jego danych źródłowych. Aby uzyskać więcej informacji o możliwościach interaktywnej pracy z danymi źródłowymi wykresu w innych wersjach przeglądarki, zapoznaj się z Pomocą do danych źródłowych.

Wykres dla sieci Web nie jest aktualizowany w przeglądarce

Jeżeli wykres był publikowany za pomocą programu Microsoft Excel, to być może nie wybrano opcji opublikowania wykresu z funkcjami interaktywnymi. Jeżeli tak się stało, to wykres jest wyświetlany w przeglądarce jako obiekt statyczny i nie jest połączony z danymi.

Aby opublikować interaktywny wykres, otwórz oryginalny skoroszyt w programie Excel, zaznacz wykres, a następnie kliknij polecenie Zapisz jako stronę sieci Web w menu Plik. W oknie dialogowym Zapisz jako kliknij opcję Wybór: wykres i zaznacz pole wyboru Dodaj interakcję.

Kliknięcie przycisku Edytuj w przeglądarce sieci Web powoduje otwarcie strony sieci Web w niewłaściwym programie.

Programy udostępniane przez kliknięcie przycisku Edytuj w przeglądarce sieci Web zależą od tego, w jaki sposób strona została opublikowana.

Jeżeli kliknięcie przycisku Edytuj w przeglądarce sieci Web otwiera program, którego nie chcesz używać, to zamknij ten program, uruchom żądany program, a następnie otwórz stronę sieci Web w tym programie.